Closed Bug 1433308 Opened 2 years ago Closed Last year

Review 'mach android-emulator' configurations/avds

Categories

(Firefox for Android :: Testing, enhancement, P5)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 65
Tracking Status
firefox65 --- fixed

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Attachments

(1 file)

Are existing configuration up to date? Consistent with mozharness? Should new ones be added?
Blocks: 1425322
Keywords: leave-open
I've tested all of these configurations locally and checked that I can run mochitest/reftest/xpcshell against each. More changes to come, probably, but this is a good start.
Attachment #8945629 - Flags: review?(jmaher)
Comment on attachment 8945629 [details] [diff] [review]
update emulator command lines for 'mach android-emulator'

Review of attachment 8945629 [details] [diff] [review]:
-----------------------------------------------------------------

rubber stamp- although if this is changed, I can only imagine what comes next :)
Attachment #8945629 - Flags: review?(jmaher) → review+
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dc65d5d9ad9d
Update 'mach android-emulator' configurations; r=jmaher
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/54a14f3a2284
Follow-up to fix lint error; r=me,a=test-only
Priority: -- → P1
The current 'x86-7.0' avd is up to date: It is based on rev 8 of the android-24/x86_64 system-image (most recent revision available today).

  system-images;android-24;default;x86_64      | 8       | Intel x86 Atom_64 System Image             | system-images/android-24/default/x86_64/     

[ro.bootimage.build.date]: [Wed Jul 12 19:46:52 UTC 2017]
[ro.bootimage.build.fingerprint]: [Android/sdk_phone_x86_64/generic_x86_64:7.0/NYC/4174735:userdebug/test-keys]
See Also: → 1465210
Let's consider using swiftshader_indirect instead of swiftshader, for recent emulator versions.
Let's consider changing the default to something modern, and prefer x86 over arm: The Fennec 4.3 test environment's importance is waning, and x86 provides a much better experience.
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/18845b2e2a11
Remove Android 6.0/x86-6.0 options for mach android-emulator; r=me,a=test-only
https://hg.mozilla.org/integration/mozilla-inbound/rev/1eee411e9a96
Change mach android-emulator default to x86-7.0; r=me,a=test-only
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: P1 → P5
(In reply to Geoff Brown [:gbrown] from comment #6)
> The current 'x86-7.0' avd is up to date: It is based on rev 8 of the
> android-24/x86_64 system-image (most recent revision available today).

That is still the most recent revision today.
I tried adding an x86-9.0 variant, based on revision 4 of system-images;android-28;default;x86_64, for those living on the edge. I created an avd with:

avdmanager --verbose create avd -d pixel_xl -n mozemu28c -k 'system-images;android-28;default;x86_64' --sdcard 600M

and customized it similar to x86-7.0. That worked but was notably slower than x86-7.0.

I then tried to package it for tooltool export and ran into a problem: I couldn't get the emulator (27.3.10) to find vendor.img from a local system-img. It was okay if vendor.img was in its default location in android-sdk-linux, but not when I moved all the .img files to the avd directory and updated config.ini appropriately. I note that vendor.img is not part of x86-7.0 or earlier avds.

Perhaps this issue could be overcome with some ingenuity or special-case code for 9.0, but combined with the poor performance, I decided to put this avd aside for now. Let's revisit in a future bug when someone needs a newer test avd.
Keywords: leave-open
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ed8ea654ccde
Switch android emulator gpu from swiftshader to swiftshader_indirect; r=me,a=test-only
https://hg.mozilla.org/mozilla-central/rev/ed8ea654ccde
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 65
You need to log in before you can comment on or make changes to this bug.