Download progress meter is left-to-right when UI is right-to-left

RESOLVED FIXED

Status

()

Toolkit
XUL Widgets
RESOLVED FIXED
16 years ago
7 years ago

People

(Reporter: smontagu, Unassigned)

Tracking

({rtl})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Description: when the interface is aligned to the right, e.g. when using a RTL
language (like hebrew or arabic), the progress meter in the download manager
should move from right to left.

Steps to reproduce:
1. aligning the interface to the right: add these lines to the file intl.css, in
the locale\en-US\global, in the en-US.jar file (the language pack file, in the
chrome folder):

window,dialog,wizard,page {
  direction: rtl;
}

menu { direction: rtl; }

tree { direction: rtl; }

2. Download a file in Mozilla
3. Watch the progress meter in the download manager.

Actual results: the bar moves from left to right.
Expected results: the bar should move from right to left.

The progress meter in the status bar doesn't have this problem, btw.

Comment 1

16 years ago
-> me
Assignee: mkaply → varga

Comment 2

16 years ago
hmm, this probably makes our product unusable for some users.
Nominating for buffy.
Keywords: nsbeta1

Comment 3

16 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 4

16 years ago
i could not reproduce this on my hebrew-localised mozilla 1.0.0. for me, the
progress bar moves from right to left correctly.

Comment 5

16 years ago
I tried current mozilla trunk and 1.0 build and I still see progress meter to
move from left to right.

I have this in my userChrome.css file:
tree {
  direction: rtl;
}

Are you sure you checked progress meter in download manager ?
It's not opened by default in 1.0 build.

Comment 6

16 years ago
i saw it in the dialog that opens when you download a file, the one that shows
you the file name, size, elapsed time and time left. isn't that the download
manager?

did you have the dialoge in RTL? try adding the other lines Simon wrote here:

window,dialog,wizard,page {
  direction: rtl;
}

menu { direction: rtl; }

(although you know better than me what they mean).

Comment 7

16 years ago
Do you mean Tools -> Download manager ?

Comment 8

16 years ago
oh, that download manager :o

well, umm, oops..

<crawling under the carpet in embaressment>
I'll check this soon...
This will be solved when the patch for bug 140759 will be checked in, adding
dependence
Depends on: 140759
(Reporter)

Updated

14 years ago
Assignee: varga → romano_a
Patch reviewed, change status to ASSIGNED.
Status: NEW → ASSIGNED
Assignee: bugs.mano → nobody
Status: ASSIGNED → NEW
QA Contact: zach → layout.bidi
Fixed as bug 297780?
Er, that bug is for undetermined progress-meter.

Updated

9 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: layout.bidi → layout.fonts-and-text

Updated

9 years ago
Component: Layout: Text → XUL Widgets
Keywords: rtl
Product: Core → Toolkit
QA Contact: layout.fonts-and-text → xul.widgets
(Reporter)

Comment 14

7 years ago
FIXED, presumably by 140759 as comment 10 says
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.