Scrollbars aren't displayed on some pages or after zooming

RESOLVED DUPLICATE of bug 1281907

Status

()

defect
P3
normal
RESOLVED DUPLICATE of bug 1281907
2 years ago
Last year

People

(Reporter: JanH, Unassigned)

Tracking

unspecified
All
Android
Points:
---

Firefox Tracking Flags

(fennec+, firefox58 wontfix, firefox59 affected, firefox60 affected)

Details

(Whiteboard: [gfx-noted])

This affects some, but not all pages.

Working:
http://www.456bereastreet.com/lab/html5-input-types/
https://developer.mozilla.org/en-US/docs/Web/HTML/Element/datalist

Not working:
http://ftp.mozilla.org/pub/mobile/nightly/latest-mozilla-central-android-api-16/
http://www.456bereastreet.com/lab/html5-input-types/

I'm not absolutely certain yet, but I've got a feeling that pages in the "not working" category are mainly/only (?) Desktop pages without a corresponding <meta viewport tag.

Additionally, even on pages in the "working" category, the scroll bars disappear if I pinch zoom in/out from the original zoom level.

On the MDN page, zooming out restores the scroll bars, presumably because I can't zoom out further than the initial zoom level, while on 456bereastreet.com, which uses <meta name="viewport" content="width=320; initial-scale=1.0;"> I can zoom back out further than the initial zoom level, in which case the scroll bars go AWOL as well.

Hazarding a guess (haven't checked it yet), the scrollbars are possibly only displayed properly when the zoom level (document resolution) is ≈ 1.0?
See Also: → 1281907
tracking-fennec: --- → ?
tracking-fennec: ? → +
Component: General → Panning and Zooming
Product: Firefox for Android → Core
What I said at https://bugzilla.mozilla.org/show_bug.cgi?id=1281907#c3 applies here too.
Priority: -- → P3
Whiteboard: [gfx-noted]
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
See Also: 1281907
Duplicate of bug: 1281907
You need to log in before you can comment on or make changes to this bug.