Closed Bug 1433703 Opened 2 years ago Closed 2 years ago

screentopng: error while loading shared libraries: libXss.so.1

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(2 files)

So one of the things that *did* apparently change between building on CentOS and building on Debian, is that the screenshot tool is not built the same way. That went undetected because it's not shipped with Firefox, and because it requires an active failure on some kinds of tests to trigger. Plus, it works on linux64, it only fails on linux32.

So what's different? The Debian image has libxss-dev installed, and the CentOS image didn't. That makes the screenshot code activate the libxss code, which was added back in bug 414049 to catch things like bug 585286.

Obviously, this means this code hasn't been used in a long time: at least since we switched to those CentOS images. That might be a change from when we switched from buildbot to taskcluster, but that might be even older.

Now, the reason it only fails on linux32 is that the ubuntu images used for tests actually have libxss installed, but only the amd64 package, not the i386 one, so screentopng works when it's a 64-bit binary, but not when it's a 32-bit one.

There are two ways out of this:
- Remove the libxss-dev package from the build image.
- Install the libxss1:i386 package on the test image.

If we go with the former, we might as well remove the libxss support code from the screenshot tool.

I don't really care either way, but the former has been the status quo for years. Ted, since you were involved in writing this code, what's your take?
Flags: needinfo?(ted)
Duplicate of this bug: 1433688
Let's go with the former. Considering the fact that we have much greater control over the test environment these days I don't think there's much value in having the libxss code, so we might as well make things work the way they had been recently.
Flags: needinfo?(ted)
Comment on attachment 8946548 [details]
Bug 1433703 - Remove the libxss-dev package from the build image.

https://reviewboard.mozilla.org/r/216570/#review222250
Attachment #8946548 - Flags: review+
Comment on attachment 8946549 [details]
Bug 1433703 - Remove the libxss-based code from the screenshot tool.

https://reviewboard.mozilla.org/r/216572/#review222252
Attachment #8946549 - Flags: review+
Attachment #8946548 - Flags: review?(core-build-config-reviews)
Attachment #8946549 - Flags: review?(core-build-config-reviews)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/f1ec38bffa53
Remove the libxss-dev package from the build image. r=gps
https://hg.mozilla.org/integration/autoland/rev/a23e3bbd2019
Remove the libxss-based code from the screenshot tool. r=gps
https://hg.mozilla.org/mozilla-central/rev/f1ec38bffa53
https://hg.mozilla.org/mozilla-central/rev/a23e3bbd2019
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.