Closed Bug 1433718 Opened 2 years ago Closed 2 years ago

Add unit test for enabling the split rule view

Categories

(DevTools :: Inspector, enhancement, P3)

enhancement

Tracking

(firefox62 fixed)

RESOLVED FIXED
Firefox 62
Tracking Status
firefox62 --- fixed

People

(Reporter: gl, Assigned: gl)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

Attachments

(1 file, 1 obsolete file)

1. Enable the split rule view
2. Make sure the existing unit tests are working
3. Add integration tests for toggling on/off the split rule view.
This patch both always shows the button and enables the feature by default across all channels. I would have expected that we would have given it some time on-by-default in Nightly and have product drive the decision on when it should ride the train. And then if there's a chance it would stay Nightly-only past the merge we'd want to keep the devtools.inspector.split-sidebar-toggle pref around so the button doesn't show up for everyone. It's possible I'm out of the loop here - I can do the code review if this is intentional.
Flags: needinfo?(gl)
(In reply to Brian Grinstead [:bgrins] from comment #2)
> This patch both always shows the button and enables the feature by default
> across all channels. I would have expected that we would have given it some
> time on-by-default in Nightly and have product drive the decision on when it
> should ride the train. And then if there's a chance it would stay
> Nightly-only past the merge we'd want to keep the
> devtools.inspector.split-sidebar-toggle pref around so the button doesn't
> show up for everyone. It's possible I'm out of the loop here - I can do the
> code review if this is intentional.

The intention is to ship the 3 pane inspector in FF60. You can see from the bugs that I am pushing on polishing it and getting everything ready to be enabled as soon as possible so we can have as much time in Nightly for feedback.
Flags: needinfo?(gl)
Attachment #8946165 - Flags: review?(bgrinstead)
I seem to remember there being some perf regression on the initial bug which led us to land it off by default in Nightly. Are we OK with taking a startup regression? If not, is there work planned to make it faster? Getting some fresh damp numbers with this patch applied would help get a sense of the size of it.
Attachment #8946165 - Attachment is obsolete: true
Attachment #8946165 - Attachment is patch: true
Attachment #8946165 - Attachment mime type: text/x-review-board-request → text/plain
This is the latest damp results of what happens when we try to enable the 3 pane by default. https://treeherder.mozilla.org/perf.html#/compare?originalProject=try&newProject=try&newRevision=00f1851a3d47b1c3c231c574d174cdb68c78614f&framework=1&selectedTimeRange=172800

Pinging Alex to make sure you are aware of this perf regression and also asking what we can do to try to mitigate this.
Flags: needinfo?(poirot.alex)
This is still regressing inspector perf a lot. Between 15 to 25% slower to open, this is big!
You can see it that via:
* cold.inspector.open (Cold startup, i.e. when that's the first tool to load) 15% slower,
* complicated.inspector.open (Opening the inspector against bild.de copy) 21% slower,
* simple.inspector.open (Opening the inspector against a blank page) 24% slower.

Note that some other usages of the inspector are slower:
* custom.inspector.manyrules.selectnode (Selecting a node with many rules) 7% slower,
* custom.inspector.expandall.balanced (Expanding a large DOM tree) 5% slower.

The rest of DAMP report can be just noise introduced by the significant regression of the other tests.

Now, given that the regression is big, you should easily be able to see the culprit by looking at perf-html data:
  https://perfht.ml/2vVbv4S

Briefly looking at it, I see:
* why do we load resource://devtools/client/inspector/layout/layout.js?
* I see BoxModelEditable/BoxModelInfo render method, but it doesn't seem to be displayed?
* HTMLTooltip is created, does it really has to on inpector opening? Can't it wait for an action requiring to display one?
* updateDebuggerPausedWarning function access NotificationBox, which seems slow to startup and not displayed
* setupSplitter may be slow for some reason
* TextPropertyEditor calls parseCssProperty which looks very slow. Does it call it many times or is it super slow? Can we lazily call it? It may be a very big source of slowness overall.
* I see a couple of Promise.jsm stack, we may get some free win by removing it (I should be able to do it soon)
* scrollIntoViewIfNeeded appears in the profile, it may be tweaked based on our experience on console and netmonitor.

It's not really the 3 panes that is slower, I imagine this is mostly the cost of displaying the computed view.
But as I worked quite hard to get the inspector to load significantly faster last august/september, I wish we could not regress it and trade the regression here by speeding up our existing features. Looking at this profile, it looks like there is room for improvement in a couple of places!
Flags: needinfo?(poirot.alex)
(In reply to Alexandre Poirot [:ochameau] from comment #6)
> This is still regressing inspector perf a lot. Between 15 to 25% slower to
> open, this is big!
> You can see it that via:
> * cold.inspector.open (Cold startup, i.e. when that's the first tool to
> load) 15% slower,
> * complicated.inspector.open (Opening the inspector against bild.de copy)
> 21% slower,
> * simple.inspector.open (Opening the inspector against a blank page) 24%
> slower.
> 
> Note that some other usages of the inspector are slower:
> * custom.inspector.manyrules.selectnode (Selecting a node with many rules)
> 7% slower,
> * custom.inspector.expandall.balanced (Expanding a large DOM tree) 5% slower.
> 
> The rest of DAMP report can be just noise introduced by the significant
> regression of the other tests.
> 
> Now, given that the regression is big, you should easily be able to see the
> culprit by looking at perf-html data:
>   https://perfht.ml/2vVbv4S
> 
> Briefly looking at it, I see:
> * why do we load resource://devtools/client/inspector/layout/layout.js?
> * I see BoxModelEditable/BoxModelInfo render method, but it doesn't seem to
> be displayed?
> * HTMLTooltip is created, does it really has to on inpector opening? Can't
> it wait for an action requiring to display one?
> * updateDebuggerPausedWarning function access NotificationBox, which seems
> slow to startup and not displayed
> * setupSplitter may be slow for some reason
> * TextPropertyEditor calls parseCssProperty which looks very slow. Does it
> call it many times or is it super slow? Can we lazily call it? It may be a
> very big source of slowness overall.
> * I see a couple of Promise.jsm stack, we may get some free win by removing
> it (I should be able to do it soon)
> * scrollIntoViewIfNeeded appears in the profile, it may be tweaked based on
> our experience on console and netmonitor.
> 
> It's not really the 3 panes that is slower, I imagine this is mostly the
> cost of displaying the computed view.
> But as I worked quite hard to get the inspector to load significantly faster
> last august/september, I wish we could not regress it and trade the
> regression here by speeding up our existing features. Looking at this
> profile, it looks like there is room for improvement in a couple of places!

Thanks Alex, this is exactly what I am looking for and hoping we can mitigate this as much as possible before shipping this.
Thanks Alex for the useful profile analysis.
I agree on the approach too: 3 pane is a new feature that we want our users to have, we know it displays 2 sidebar panels instead of 1, so we expected the perf regression. So let's try to make various parts of the inspector faster so we can make this regression as small as possible before shipping the overall 3 pane.
Hopefully some of it can be low-hanging fruits.

> * HTMLTooltip is created, does it really has to on inpector opening? Can't
> it wait for an action requiring to display one?
Definitely feels like a good one to lazify. We only show them on mouseover.

> * TextPropertyEditor calls parseCssProperty which looks very slow. Does it
> call it many times or is it super slow? Can we lazily call it? It may be a
> very big source of slowness overall.
We know the rule view is slow when many properties are displayed, but we can't really lazify any of it. CSS rules need to be displayed from the start, in 2 pane and 3 pane mode.
Comment on attachment 8972496 [details]
Bug 1433718 - Make unit tests pass with the 3 pane inspector on in nightly.

https://reviewboard.mozilla.org/r/216156/#review246892

I'm ready to R+ the change but I want to make sure of 2 things first:

- We need to have a plan for migrating the remaining tests that do not work with 3 pane yet (those that do `await pushPref("devtools.inspector.three-pane-enabled", false);` because they fail otherwise). A bug should be filed.
- And, we need to make sure tests will still pass after nightly: the pref defaults to true on nightly only, so we need to check what happens once this commit reaches beta.

::: devtools/client/preferences/devtools-client.js:52
(Diff revision 3)
>  // Enable the 3 pane mode toggle in the inspector
>  #if defined(NIGHTLY_BUILD)
>  pref("devtools.inspector.three-pane-toggle", true);
>  #else
>  pref("devtools.inspector.three-pane-toggle", false);
>  #endif
>  // Enable the 3 pane mode in the inspector
> +#if defined(NIGHTLY_BUILD)
> +pref("devtools.inspector.three-pane-enabled", true);
> +#else
>  pref("devtools.inspector.three-pane-enabled", false);
> +#endif

Maybe you could merge those 2 sections into one. On Nightly we want both the toggle and the 3 pane mode on. And we want them both off elsewhere.
Attachment #8972496 - Flags: review?(pbrosset)
Blocks: 1459002
Comment on attachment 8972496 [details]
Bug 1433718 - Make unit tests pass with the 3 pane inspector on in nightly.

https://reviewboard.mozilla.org/r/216156/#review247460
Attachment #8972496 - Flags: review?(pbrosset) → review+
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4832928b4bb4
Make unit tests pass with the 3 pane inspector on in nightly. r=pbro
Flags: needinfo?(gl)
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b7aeba47bb1f
Make unit tests pass with the 3 pane inspector on in nightly. r=pbro
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/19576ace167c
Follow up: fix eslint errors in rule-editor.js; r=me
Backout by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/18f6c21aeef4
Backed out 2 changesets for devtools failures on markup/test/browser_markup_events_react_development_15.4.1_jsx.js
Backed out 2 changesets (bug 1433718) for devtools failures on markup/test/browser_markup_events_react_development_15.4.1_jsx.js

Backout link: https://hg.mozilla.org/integration/mozilla-inbound/rev/18f6c21aeef4ea2ad56e79fc8e39e6c3799a3a62

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=b7aeba47bb1fdac1946cc2afcf19accaf4ff4c91

Log link: https://treeherder.mozilla.org/logviewer.html#?job_id=177093704&repo=mozilla-inbound&lineNumber=5648

Log snippet: 
05:22:58     INFO -  3486 INFO TEST-START | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js
05:22:59     INFO -  3487 INFO Entering test bound
05:22:59     INFO -  3488 INFO Adding a new tab with URL: http://example.com/browser/devtools/client/inspector/markup/test/doc_markup_events_react_development_15.4.1_jsx.html
05:22:59     INFO -  3489 INFO Tab added and finished loading
05:22:59     INFO -  3490 INFO Opening the inspector
05:22:59     INFO -  3491 INFO Opening the toolbox
05:22:59     INFO -  GECKO(1284) | console.log: "[DISPATCH]" "{\n  \"type\": \"UPDATE_SHOW_GRID_AREAS\",\n  \"enabled\": false\n}"
05:22:59     INFO -  GECKO(1284) | console.log: "[DISPATCH]" "{\n  \"type\": \"UPDATE_SHOW_GRID_LINE_NUMBERS\",\n  \"enabled\": false\n}"
05:22:59     INFO -  GECKO(1284) | console.log: "[DISPATCH]" "{\n  \"type\": \"UPDATE_SHOW_INFINITE_LINES\",\n  \"enabled\": false\n}"
05:23:00     INFO -  3492 INFO Toolbox opened and focused
05:23:00     INFO -  3493 INFO Getting the markup-container for node #inlinejsx
05:23:00     INFO -  3494 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | Found markup-container for selector: #inlinejsx -
05:23:00     INFO -  3495 INFO Selecting the node for '#inlinejsx'
05:23:00     INFO -  3496 INFO Clicking evHolder
05:23:00     INFO -  3497 INFO tooltip shown
05:23:00     INFO -  3498 INFO Processing header[0] for H3#inlinejsx
05:23:00     INFO -  3499 INFO Looking for click
05:23:00     INFO -  3500 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | type matches for H3#inlinejsx -
05:23:00     INFO -  3501 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | filename matches for H3#inlinejsx -
05:23:00     INFO -  3502 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | we have the correct number of attributes -
05:23:00     INFO -  3503 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[0] matches for H3#inlinejsx -
05:23:00     INFO -  3504 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[1] matches for H3#inlinejsx -
05:23:00     INFO -  3505 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are not in expanded state -
05:23:00     INFO -  3506 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are in expanded state and icon changed -
05:23:00     INFO -  3507 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | handler matches for H3#inlinejsx -
05:23:00     INFO -  3508 INFO Processing header[1] for H3#inlinejsx
05:23:00     INFO -  3509 INFO Looking for onClick
05:23:00     INFO -  3510 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | type matches for H3#inlinejsx -
05:23:00     INFO -  3511 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | filename matches for H3#inlinejsx -
05:23:00     INFO -  3512 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | we have the correct number of attributes -
05:23:00     INFO -  3513 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[0] matches for H3#inlinejsx -
05:23:00     INFO -  3514 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[1] matches for H3#inlinejsx -
05:23:00     INFO -  3515 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are not in expanded state -
05:23:00     INFO -  3516 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are in expanded state and icon changed -
05:23:00     INFO -  3517 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | handler matches for H3#inlinejsx -
05:23:00     INFO -  3518 INFO Getting the markup-container for node #externaljsx
05:23:00     INFO -  3519 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | Found markup-container for selector: #externaljsx -
05:23:00     INFO -  3520 INFO Selecting the node for '#externaljsx'
05:23:00     INFO -  3521 INFO Clicking evHolder
05:23:00     INFO -  3522 INFO tooltip shown
05:23:00     INFO -  3523 INFO Processing header[0] for H3#externaljsx
05:23:00     INFO -  3524 INFO Looking for click
05:23:00     INFO -  3525 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | type matches for H3#externaljsx -
05:23:00     INFO -  3526 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | filename matches for H3#externaljsx -
05:23:00     INFO -  3527 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | we have the correct number of attributes -
05:23:00     INFO -  3528 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[0] matches for H3#externaljsx -
05:23:00     INFO -  3529 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[1] matches for H3#externaljsx -
05:23:00     INFO -  3530 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are not in expanded state -
05:23:00     INFO -  3531 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are in expanded state and icon changed -
05:23:00     INFO -  3532 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | handler matches for H3#externaljsx -
05:23:00     INFO -  3533 INFO Processing header[1] for H3#externaljsx
05:23:00     INFO -  3534 INFO Looking for onClick
05:23:00     INFO -  3535 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | type matches for H3#externaljsx -
05:23:00     INFO -  3536 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | filename matches for H3#externaljsx -
05:23:00     INFO -  3537 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | we have the correct number of attributes -
05:23:00     INFO -  3538 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[0] matches for H3#externaljsx -
05:23:00     INFO -  3539 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[1] matches for H3#externaljsx -
05:23:00     INFO -  3540 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are not in expanded state -
05:23:01     INFO -  3541 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are in expanded state and icon changed -
05:23:01     INFO -  3542 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | handler matches for H3#externaljsx -
05:23:01     INFO -  3543 INFO Getting the markup-container for node #externalinlinejsx
05:23:01     INFO -  3544 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | Found markup-container for selector: #externalinlinejsx -
05:23:01     INFO -  3545 INFO Selecting the node for '#externalinlinejsx'
05:23:01     INFO -  3546 INFO Clicking evHolder
05:23:01     INFO -  3547 INFO tooltip shown
05:23:01     INFO -  3548 INFO Processing header[0] for H3#externalinlinejsx
05:23:01     INFO -  3549 INFO Looking for click
05:23:01     INFO -  3550 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | type matches for H3#externalinlinejsx -
05:23:01     INFO -  3551 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | filename matches for H3#externalinlinejsx -
05:23:01     INFO -  3552 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | we have the correct number of attributes -
05:23:01     INFO -  3553 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[0] matches for H3#externalinlinejsx -
05:23:01     INFO -  3554 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[1] matches for H3#externalinlinejsx -
05:23:01     INFO -  3555 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are not in expanded state -
05:23:01     INFO -  3556 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are in expanded state and icon changed -
05:23:01     INFO -  3557 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | handler matches for H3#externalinlinejsx -
05:23:01     INFO -  3558 INFO Processing header[1] for H3#externalinlinejsx
05:23:01     INFO -  3559 INFO Looking for onClick
05:23:01     INFO -  3560 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | type matches for H3#externalinlinejsx -
05:23:01     INFO -  3561 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | filename matches for H3#externalinlinejsx -
05:23:01     INFO -  3562 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | we have the correct number of attributes -
05:23:01     INFO -  3563 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[0] matches for H3#externalinlinejsx -
05:23:01     INFO -  3564 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[1] matches for H3#externalinlinejsx -
05:23:01     INFO -  3565 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are not in expanded state -
05:23:01     INFO -  3566 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are in expanded state and icon changed -
05:23:01     INFO -  3567 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | handler matches for H3#externalinlinejsx -
05:23:01     INFO -  3568 INFO Processing header[2] for H3#externalinlinejsx
05:23:01     INFO -  3569 INFO Looking for onMouseUp
05:23:01     INFO -  3570 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | type matches for H3#externalinlinejsx -
05:23:01     INFO -  3571 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | filename matches for H3#externalinlinejsx -
05:23:01     INFO -  3572 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | we have the correct number of attributes -
05:23:01     INFO -  3573 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[0] matches for H3#externalinlinejsx -
05:23:01     INFO -  3574 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | attribute[1] matches for H3#externalinlinejsx -
05:23:01     INFO -  3575 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are not in expanded state -
05:23:01     INFO -  3576 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | We are in expanded state and icon changed -
05:23:01     INFO -  3577 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | handler matches for H3#externalinlinejsx -
05:23:01     INFO -  3578 INFO Getting the markup-container for node #externalcapturingjsx
05:23:01     INFO -  3579 INFO TEST-PASS | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | Found markup-container for selector: #externalcapturingjsx -
05:23:01     INFO -  3580 INFO Selecting the node for '#externalcapturingjsx'
05:23:01     INFO -  3581 INFO Clicking evHolder
05:23:44     INFO -  3582 INFO Longer timeout required, waiting longer...  Remaining timeouts: 3
05:24:29     INFO -  3583 INFO Longer timeout required, waiting longer...  Remaining timeouts: 2
05:25:14     INFO -  3584 INFO Longer timeout required, waiting longer...  Remaining timeouts: 1
05:25:59     INFO -  TEST-INFO | started process screenshot
05:25:59     INFO -  TEST-INFO | screenshot: exit 0
05:25:59    ERROR -  3585 INFO TEST-UNEXPECTED-FAIL | devtools/client/inspector/markup/test/browser_markup_events_react_development_15.4.1_jsx.js | Test timed out -
Flags: needinfo?(gl)
Flags: needinfo?(gl)
Pushed by gabriel.luong@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6d96ce013811
Enable 3 pane inspector in nightly and make unit tests pass. r=pbro
https://hg.mozilla.org/mozilla-central/rev/6d96ce013811
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Product: Firefox → DevTools
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.