Ctrl+W to close current tab and open a new tab (when only 1 tab is opened)

RESOLVED DUPLICATE of bug 456405

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 456405
26 days ago
26 days ago

People

(Reporter: In, Unassigned)

Tracking

58 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

26 days ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180118215408

Steps to reproduce:

1.Open a tab
2.Close it using Ctrl+W


Actual results:

Program closes


Expected results:

Current tab should have closed and new tab should been opened
-----------------------------------------------
Ctrl+W is for tabs not for windows
This should happen only when the current tab has somethings opened in it(not when the current tab is new tab)

Comment 1

26 days ago
Set browser.tabs.closeWindowWithLastTab to false in about:config.
Status: UNCONFIRMED → RESOLVED
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Last Resolved: 26 days ago
Component: Untriaged → Tabbed Browser
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 456405
(Reporter)

Comment 2

26 days ago
(In reply to Gingerbread Man from comment #1)
> Set browser.tabs.closeWindowWithLastTab to false in about:config.

Shouldn't it be false by default.
You need to log in before you can comment on or make changes to this bug.