Status

()

defect
P1
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: philipp, Assigned: bas.schouten)

Tracking

({crash, regression})

58 Branch
mozilla60
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58+ fixed, firefox59 fixed, firefox60 fixed)

Details

(Whiteboard: [gfx-noted], crash signature)

Attachments

(1 attachment)

This bug was filed from the Socorro interface and is
report bp-af1e6a31-292a-4f7c-aa44-d7edd0180124.
=============================================================

content crashes on windows 7 64bit with this intel graphics driver in the signature started taking off in with firefox 58:
https://crash-stats.mozilla.com/signature/?product=Firefox&process_type=content&submitted_from_infobar=%21__true__&signature=igd10umd64.dll&date=%3E%3D2017-12-24#graphs
so far in the 58 roll-out it's the #3 top content crasher with 1.8% of all tab crashes.

the spike seems to be mostly restricted to a particular driver version and one generation of intel gpus, so perhaps it would be possible to do something here with the help of a remote blocklist?

Adapter driver version facet
1 	8.15.10.2418 	583 	97.65 %

Adapter device id facet
1 	0x0116 	225 	37.69 %
2 	0x0126 	175 	29.31 %
3 	0x0102 	158 	26.47 %
4 	0x0106 	33 	5.53 %
5 	0x0112 	3 	0.50 %
Flags: needinfo?(milan)
Bas, can we make something out of these crashes, or is the blocklisting our only option?  Why the spike?  Related to OMTP?  I can't tell if it is OMTP, but it doesn't seem to be on the paint thread?
Flags: needinfo?(milan) → needinfo?(bas)
Whiteboard: [gfx-noted]
(In reply to Milan Sreckovic [:milan] from comment #1)
> Bas, can we make something out of these crashes, or is the blocklisting our
> only option?  Why the spike?  Related to OMTP?  I can't tell if it is OMTP,
> but it doesn't seem to be on the paint thread?

This definitely seems to be OMTP related, note that in all these crashes the main thread is actually performing D2D operations and is waiting for what seems to be getting the D2D global lock. Considering the small size of this group, blacklisting for D2D (or OMTP) on this driver version and OS version is probably the right course of action. This is unlikely to be an actual 'bug' on our side, and probably a threading issue inside that driver version. Note that this is also a very old driver.
Flags: needinfo?(bas)
Bas, can you put together a patch to block this in code?  I can then put one together for downloadable blocklist.
Assignee: nobody → bas
Flags: needinfo?(bas)
Comment on attachment 8947512 [details]
Bug 1433790: Disable Direct2D on drivers/devices where OMTP causes crashes.

https://reviewboard.mozilla.org/r/217218/#review223034
Attachment #8947512 - Flags: review?(milan) → review+
Pushed by bschouten@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fe003f33c158
Disable Direct2D on drivers/devices where OMTP causes crashes. r=milan
Done.
Flags: needinfo?(bas)
https://hg.mozilla.org/mozilla-central/rev/fe003f33c158
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
could you request uplift to beta and perhaps release as well? thnx
Flags: needinfo?(bas)
Comment on attachment 8947512 [details]
Bug 1433790: Disable Direct2D on drivers/devices where OMTP causes crashes.

Approval Request Comment
[Feature/Bug causing the regression]: OMTP
[User impact if declined]: Crashes on some drivers.
[Is this code covered by automated tests?]: Yes
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: Simply blacklisting D2D on some devices where D2D benefits were modest at best.
[String changes made/needed]: None
Flags: needinfo?(bas)
Attachment #8947512 - Flags: approval-mozilla-beta?
Let's do release through the downloadable blacklist unless that somehow doesn't work.
i think there were plans for a 58.0.2 release this week for bug 1433591 anyway - the patch here could be a nice ridealong to that.
Comment on attachment 8947512 [details]
Bug 1433790: Disable Direct2D on drivers/devices where OMTP causes crashes.

Let's make sure it gets into 59b7 today at least.
Attachment #8947512 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Comment on attachment 8947512 [details]
Bug 1433790: Disable Direct2D on drivers/devices where OMTP causes crashes.

We might want to also ship this on release if there's a dot release scheduled, however doing it through the downloadable blacklist or a system add-on is probably a faster way to get this to users at this point.
Attachment #8947512 - Flags: approval-mozilla-release?
Comment on attachment 8947512 [details]
Bug 1433790: Disable Direct2D on drivers/devices where OMTP causes crashes.

Checked with Milan, this is a low risk ride-along that we plan to include in 58.0.2.
Attachment #8947512 - Flags: approval-mozilla-release? → approval-mozilla-release+
You need to log in before you can comment on or make changes to this bug.