Closed Bug 1433987 Opened 3 years ago Closed 3 years ago

Disabling "media.autoplay.enabled" causes NBC News videos to not work

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: yoasif, Unassigned)

References

Details

(Keywords: nightly-community)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180129100406

Steps to reproduce:

1. Navigate to https://www.nbcnews.com/politics/politics-news/fbi-deputy-director-andrew-mccabe-stepping-down-n842176
2. Click play icon on video on page



Actual results:

Video does not play and endlessly shows loading spinner. 


Expected results:

Video should play, like when media.autoplay.enabled is set to true.
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Component: General → Audio/Video: Playback
Thanks for the report. We're working on a feature to improve the interaction between media.autoplay.enabled and websites. You can test it by also setting media.autoplay.enabled.user-gestures-needed to true in Firefox Nightly.

I can reproduce the long delay, but also see it when media.autoplay.enabled is set to true. Not sure what's going on there.

Chris, it looks like this site is trying to autoplay on mouse-over. Or rather, it shows a no-audio clip on mouse-over, then a countdown overlay, then autoplays the real video. Do you have any insight to add?
Flags: needinfo?(cpearce)
Priority: -- → P3
setting media.autoplay.enabled.user-gestures-needed to true improves the situation - the video plays after a few seconds. Previously, it did not play at all.
(In reply to Ralph Giles (:rillian) | needinfo me from comment #1)
> Chris, it looks like this site is trying to autoplay on mouse-over. Or
> rather, it shows a no-audio clip on mouse-over, then a countdown overlay,
> then autoplays the real video. Do you have any insight to add?

Only that our user-gesture-needed code won't authorize on mouse-over, so if someone lands on this page from a deep link, they may end up not being able to play. The site needs to handle the play() promise reject...
Flags: needinfo?(cpearce)
This seems to be working as expected now with the new block autoplay behavivour.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.