padlock (SSL) is always visible as "secure" when through all the tabs

VERIFIED DUPLICATE of bug 101723

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 101723
16 years ago
14 years ago

People

(Reporter: olivier, Assigned: Matti)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-GB; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

In a tab, open a HTTPS page where SSL is needed. This will force the padlock
(bottom-right corner of the browser) to turn yellow and look like it is locked.
Open another tab and display another page which does not require HTTPS.
Though you are now looking at a page that is not secured, you think it is secure
because the padlock remains yellow and locked

Reproducible: Always
Steps to Reproduce:
1.Open an HTTPS page in a tab (check that the padlock is yellow and locked)
2.Open another tab. Display a normal, non-secure page (HTTP).
3. Check the padlock. It remains yellow and locked. It should be unlocked on the
HTTP page, and changed to locked and yellow on the secure page

Actual Results:  The padlock remains in a state of "secure page", when browsing
a page that is not

Expected Results:  The padlock should change its status when switching from a
tab containing a secure content (yellow and locked), to a page containing
non-secure content (unlocked)

Comment 1

16 years ago
This has been fixed after the release of 0.9.9.
Please try a newer build.

*** This bug has been marked as a duplicate of 101723 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

16 years ago
v (could be also invalid because the Build ID is tto old)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.