Closed Bug 1434581 Opened 2 years ago Closed 2 years ago

Click on button does not submit form (nothing happens)

Categories

(Toolkit :: Form Autofill, defect)

59 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1433876

People

(Reporter: nachtigall, Assigned: selee)

References

Details

Attachments

(2 files)

40.68 KB, image/png
Details
844.51 KB, application/x-zip-compressed
Details
I run mozregression and it points me to this pushlog https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=8ee11d296e382c36a26c67a9aad7dfe2a74ad745&tochange=325e9306bf096bd506c327ed65503dbaa7c9016f and hence Bug 1426561.

The "button => click => form is submitted" works on Firefox 58, on FDE 59.0b5 but not on Nightly. It also works on Chrome.

The example page is on a private backend page and contains private data, so I would not like to put it on the internet. But please feel free to drop me an e-mail and I can send the page to you via mail.
Sorry, forgot my mail address: nachtigall (at) web (dot) de

FWIW, the bug is reproducable on Windows 10 and Ubuntu Linux.

Setting NI to lukechang1209(at)__gmail.com because BMO says: " You can't ask Sean Lee [:seanlee][:weilonge] <selee____AT___mozilla.com> because that account is disabled. "
Assignee: nobody → selee
Blocks: 1426561
Flags: needinfo?(lukechang1209)
Attached image str_bug.png
STR:

See Screenshot.
0. Open saved webpage from attached Zip
1. Change Dropdown from "Aktiv" to something else, e.g. "Pausiert"
3. Click "Abo speichern" button

Expected results:

The buttons causes a form submission (which would mean a 404) in this case)

AR:

Nothing happens.

NB: If you do not change the Dropdown, then it works.
Attached file bug.zip
Has Regression Range: --- → yes
Has STR: --- → yes
I'm fixing this in bug 1433876. Thanks for the report
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(lukechang1209)
Resolution: --- → DUPLICATE
Duplicate of bug: 1433876
You need to log in before you can comment on or make changes to this bug.