Closed Bug 1434599 Opened 2 years ago Closed 2 years ago

Enable mochitest dom/serviceworkers/test/test_workerupdatefoundevent.html

Categories

(Core :: DOM: Service Workers, enhancement, P2)

All
Unspecified
enhancement

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: catalinb, Assigned: catalinb)

References

Details

Attachments

(1 file, 2 obsolete files)

This test was disabled in bug 1433276.
Assignee: nobody → catalin.badea392
The test is fine, the js error was due to the update event being received before
starting to control any clients. The original version of the worker script
would register .onupdatefound after the worker was activated.
Attachment #8947085 - Flags: review?(bkelly)
Comment on attachment 8947085 [details] [diff] [review]
Enable test_workerupdatefoundevent.html.

Review of attachment 8947085 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!

::: dom/serviceworkers/test/mochitest.ini
@@ +340,5 @@
>  [test_update_missing_imported_script.html]
>  [test_workerUnregister.html]
>  [test_workerUpdate.html]
>  [test_workerupdatefoundevent.html]
> +#skip-if = !e10s # Bug 1433276

Looks like you forgot to delete the line.
Attachment #8947085 - Flags: review?(bkelly) → review+
Attachment #8947085 - Attachment is obsolete: true
Pushed by catalin.badea392@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/87ef5029dd10
Enable test_workerupdatefoundevent.html. r=bkelly
Priority: -- → P2
I think the problem is we don't wait for the iframe to load and become controlled. Thus, when the worker gets the updatefoundevent it might not have a controlled client to postMessage to.
Flags: needinfo?(catalin.badea392)
Wait for client to load and assert it's controlled by the sw.
Attachment #8947122 - Attachment is obsolete: true
Keywords: checkin-needed
Pushed by cbrindusan@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/66a85897ecb2
Enable test_workerupdatefoundevent.html. r=bkelly
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/66a85897ecb2
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.