Closed Bug 1434807 Opened 3 years ago Closed 3 years ago

Deep-links into YouTube don't autoplay

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1457048

People

(Reporter: cpearce, Unassigned)

References

Details

The current block-autoplay strategy of blessing a document when a user gesture happens falls down in the case of sharing a deep link.

STR:
1. Send a URL to your buddy of a youtube video via email, chat, wahtever
2. Open the link in Firefox, the video won't autoplay, as the page hasn't had any interaction yet.

It also seems that YouTube's player gets confused, and you end up having to mash the play/pause button a few times to get playback to start.
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1457048
You need to log in before you can comment on or make changes to this bug.