Closed Bug 1434888 Opened 2 years ago Closed 9 months ago

The shortcut for the Accessibility tab doesn't work

Categories

(DevTools :: Accessibility Tools, defect)

defect
Not set

Tracking

(firefox65 verified, firefox66 verified)

VERIFIED FIXED
Firefox 66
Tracking Status
firefox65 --- verified
firefox66 --- verified

People

(Reporter: carmenf, Assigned: yzen)

References

()

Details

Attachments

(3 files)

Attached image shortcut.gif
[Affected versions]:
- Nightly 59.0a1

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have the latest try build 59.0a1 from (2018-01-05) installed

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites.
2. Open the Web Console (Ctrl+Shift+k) and click on the Toolbox Options button.
3. Click on the "Accessibility" checkbox from the Default Developer Tools section.
4. Press on Ctrl+Shift+z (Cmd+Opt+z) keys and observe what happens next.

[Expected result]:
- Accessibility tab is focused and displayed.

[Actual result]:
- Nothing happens, the Accessibility tab is not focused nor displayed.

[Notes]:
- Attached is a gif with the issue.
Will be fixed with the new build. NOTE: Shortcut is going to be updated to Cmd+Opt+A
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Hi Yura,

Tested this with the latest try build 60.0a1 (2018-02-13) and here are the results:
- On Windows and Linux, the shortcut is "Ctrl"+"Shift"+"A", which opens the Add-ons Manager page (about:addons). Thereby, I recommend changing this with a shortcut that doesn't interfere with other functionalities.
- On Mac OS, the shortcut is still "Cmd"+"Opt"+"z" and it still doesn't focus the Accessibility tab.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Sounds good, I updated and put back to the "Z" as command key. Not pushed to try yet but will be fixed.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Unfortunately the "Ctrl+Shift+Z" shrotcut is not working as expected on Windows and Linux. The shortcut works only if you previously opened the Web Console.
After further investigation I have found that the "Ctrl+Shift+Z" shortcut is already used by Mozilla for "redo" option: https://developer.mozilla.org/en-US/docs/Tools/Keyboard_shortcuts

However, on Mac OS the "Cmd+Opt+Z" shortcut for Accessibility works as expected.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Component: Developer Tools → Developer Tools: Accessibility Tools
I updated it to '0'
I have retested this issue using the latest Nightly try build (2018-03-01), but the shortcut is not working on Windows and Linux. If you press the "Ctrl+Shift+0" keyboard shortcut noting happens.

However, it seems that on Mac Os the "Cmd+Opt+0" shortcut is working as expected.
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1451357
Product: Firefox → DevTools
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
MozReview-Commit-ID: HkL5dDfo0p9
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a412f6082597
set accessibility panel command key to Shift + F10. r=gl
Comment on attachment 9030310 [details]
Bug 1434888 - set accessibility panel command key to Shift + F10. r=gl

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: None

User impact if declined: Keyboard users (including screen reader users) will not have a command key combination for the accessibility panel (already existing complaints over Twitter)

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Just added a command key combination for the panel + updated the label.

String changes made/needed: accessibility.tooltip3 in devtools/client/locales/en-US/startup.properties
Attachment #9030310 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/a412f6082597
Status: REOPENED → RESOLVED
Closed: 2 years ago10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 66
Assignee: nobody → yzenevich
NI Flod for approval on the string changes.
Flags: needinfo?(francesco.lodolo)
Yes, no problem in uplifting this early.
Flags: needinfo?(francesco.lodolo)
Ryan, can we hold off on uplifting it, there might be a conflict with the command key on windows (Shift + F10 triggers context menues). I'm gonna push a follow up to nightly that changes F10 to probably F12.
Flags: needinfo?(ryanvm)
Sure
Flags: needinfo?(ryanvm)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Pushed by yura.zenevich@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0e8109eaef4b
update accessibility panel command key from Shift + F10 to Shift + F12. r=gl,flod
Comment on attachment 9030736 [details]
Bug 1434888 - update accessibility panel command key from Shift + F10 to Shift + F12. r=gl

[Beta/Release Uplift Approval Request]

Feature/Bug causing the regression: Bug 1434888

User impact if declined: Follow up to the original patch that fixes a collision of Shift + F12 combo on Windows

Is this code covered by automated tests?: No

Has the fix been verified in Nightly?: No

Needs manual test from QE?: No

If yes, steps to reproduce: 

List of other uplifts needed: None

Risk to taking this patch: Low

Why is the change risky/not risky? (and alternatives if risky): Updated a command key combination for the panel.

String changes made/needed: accessibilityF12.commandkey in devtools/startup/locales/en-US/key-shortcuts.properties
Attachment #9030736 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/0e8109eaef4b
Status: REOPENED → RESOLVED
Closed: 10 months ago9 months ago
Resolution: --- → FIXED
Should be all done!
Flags: needinfo?(ryanvm)
Comment on attachment 9030310 [details]
Bug 1434888 - set accessibility panel command key to Shift + F10. r=gl

[Triage Comment]
Adds a command key combination for accessing the accessibility panel. String changes approved by Flod. Approved for 65.0b5.
Flags: needinfo?(ryanvm)
Attachment #9030310 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9030736 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
I have reproduced this issue using Firefox  64.0a1(2018.08.11) on Win 8.1 x64.
I can confirm this issue is fixed, I verified using Firefox 65.0b5 and 66.0a1 on Win 8.1 x64, Mac OS X 10.10.5 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.