Closed Bug 1435154 Opened 7 years ago Closed 2 years ago

webrender: tabs flicker when loading heavy pages

Categories

(Core :: Graphics: WebRender, defect, P3)

Unspecified
macOS
defect

Tracking

()

RESOLVED INCOMPLETE
Tracking Status
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- affected

People

(Reporter: Gankra, Unassigned)

References

(Blocks 1 open bug, )

Details

I can currently produce this pretty reliably on my mac by opening a new tab and going to http://store.channelfireball.com/landing

Interestingly, when I tried to take a screenshot of this, it came out corrupted! Almost the entire screenshot is transparent.
Nightly 60 x64 20180201220225 de_DE @ Debian Testing (KDE, Radeon RX480)
I can't reproduce.
OS: Unspecified → Mac OS X
Assignee: nobody → kvark
Priority: -- → P1
Can you still reproduce?
Flags: needinfo?(a.beingessner)
Yep.
Flags: needinfo?(a.beingessner)
Since WR isn't shipping yet, I'm going to assume wontfix on 60 and 61. I'll leave 62 affected for now.
Can you still reproduce? This WFM on mac nightly.
Flags: needinfo?(a.beingessner)
i'm pretty sure i saw this a couple days ago, but it might have been fixed by async-scene-building? I'll keep an eye out.
Flags: needinfo?(a.beingessner)
Sounds like this is mac-only, if it's even still happening. We certainly haven't gotten any other reports of this. Bumping to P2, but it would be good to know if you're still seeing this or if we can close it as WFM.
Assignee: kvark → nobody
Priority: P1 → P2
No longer blocks: stage-wr-nightly

Can you still reproduce?

Flags: needinfo?(a.beingessner)
Priority: P2 → P3

still happens very reliably when i load https://www.channelfireball.com/all-strategy/

although the flicker is weirder now; it's like the top half of the tabs gets erased but not the bottom? Maybe a picture caching side-effect.

Flags: needinfo?(a.beingessner)

Can't reproduce anymore, hooray!

Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED

This has gotten way worse recently, I see it all the time, including on https://www.channelfireball.com/all-strategy/ again

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
See Also: → 1558107
See Also: → 1568799

(In reply to Aria Beingessner [:Gankra] from comment #11)

This has gotten way worse recently, I see it all the time, including on https://www.channelfireball.com/all-strategy/ again

This page is gone. But I can't reproduce this with https://www.channelfireball.com/

Can you still reproduce?

Flags: needinfo?(a.beingessner)
Severity: normal → S3
Status: REOPENED → RESOLVED
Closed: 5 years ago2 years ago
Flags: needinfo?(a.beingessner)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.