Closed Bug 1435274 Opened 2 years ago Closed 2 years ago

[Forms Autofill V2] - Masked Credit Card is autofilled when master password is activated

Categories

(Toolkit :: Form Autofill, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox58 --- disabled
firefox59 --- verified
firefox60 --- verified

People

(Reporter: Gabi, Assigned: MattN)

Details

(Whiteboard: [form autofill:V2])

Attachments

(2 files)

Attached image MasterPassCancel.png
[Environment:]
Windows 10x64, Ubuntu 16.04, Mac Os 10.13.2

Nightly 60.0a1
Beta 59.0b6

[Steps:]


1. Open Firefox 
2. Save a few credit cards under Saved Credit Cards
3. Activate Master Password
4. Go to https://luke-chang.github.io/autofill-demo/basic.html
5. Double click on a field to trigger autofill
6. Select a profile to fill in
7. When master password dialog is displayed click Cancel


[Actual Result:]
Form is filled in with the credit card profile details when Cancel option is pressed, Credit Card number is masked in the form



[Expected Result:]
Form should not be autofilled if user does not enter master password
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Flags: qe-verify+
Summary: [Forms Autofill V2] - Credit Card is autofilled when master password is activated → [Forms Autofill V2] - Masked Credit Card is autofilled when master password is activated
Whiteboard: [form autofill: V2] → [form autofill:V2]
Comment on attachment 8948112 [details]
Bug 1435274 - Stop form autofilling if the master password prompt is cancelled.

https://reviewboard.mozilla.org/r/217720/#review223478

This looks good and works for me. Thanks!
Attachment #8948112 - Flags: review?(jhofmann) → review+
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/autoland/rev/ec1c4574bd3e
Stop form autofilling if the master password prompt is cancelled. r=johannh
Comment on attachment 8948112 [details]
Bug 1435274 - Stop form autofilling if the master password prompt is cancelled.

Thanks Johann!

Approval Request Comment
[Feature/Bug causing the regression]: Not sure if this is a regression but credit card support is only preffed on in non-release channels for now.
[User impact if declined]: Users who have a master password setup and choose to autofill a credit card will have their cardholder name, masked phone number (only the last few digits which is less sensitive), and expiration date still autofilled if the user cancels the master password prompt that appears upon filling.
[Is this code covered by automated tests?]: Yes, I added one for this specific area which wasn't covered.
[Has the fix been verified in Nightly?]: Not yet. I marked it qe-verify+
[Needs manual test from QE? If yes, steps to reproduce]: Probably not necessary since it was easy to reproduce and it seems like it fixed the problem for Johann and I.
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: fairly straightforward change to stop the fill process if the decrypted data isn't returned
[String changes made/needed]: None
Attachment #8948112 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/ec1c4574bd3e
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Verified as fixed with Windows 10x64, Ubuntu 16.4 and MacOS 10.13.2 on Fx 60.0a1 (2018-02-04).
Comment on attachment 8948112 [details]
Bug 1435274 - Stop form autofilling if the master password prompt is cancelled.

Low-risk fix that includes an automated test. Taking for 59b8.
Attachment #8948112 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: RESOLVED → VERIFIED
Verified as fixed in 59.0b8 with Windows 10x64, Ubuntu 16.04 and MacOS 10.13.2
You need to log in before you can comment on or make changes to this bug.