Closed Bug 1435450 Opened 2 years ago Closed 2 years ago

Sync icon keeps spinning even after sync is disabled

Categories

(Firefox :: Sync, defect)

60 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1435446
Tracking Status
firefox60 --- affected

People

(Reporter: kkumari, Unassigned)

Details

Prerequisite:
1. About:sync addon installed
2. services.sync.engine.bookmarks.buffer is set to true

STR:
1. Sign in to sync account 
2. Trigger sync
3. Open browser console and enter Weave.Service.enabled = false to disable sync

Actual: Sync get disabled but Sync icon is still spinning as syncing

Expected: Sync icon shouldn't spin when sync is disabled.
Flags: needinfo?(kit)
I think this is a dupe of bug 1435446, where a hung sync will spin the icon indefinitely. Unfortunately, there's no way to fully interrupt a sync except to quit the browser. `Weave.Service.enabled = false` will only prevent subsequent syncs, but, since we never finish the current one...
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(kit)
Resolution: --- → DUPLICATE
Duplicate of bug: 1435446
You need to log in before you can comment on or make changes to this bug.