Ctrl+Left Arrow/Right Arrow skip punctuation

VERIFIED DUPLICATE of bug 98546

Status

SeaMonkey
Composer
VERIFIED DUPLICATE of bug 98546
16 years ago
13 years ago

People

(Reporter: Ken Beal, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Ctrl+Left Arrow/Right Arrow skip punctuation.  I just copied the first sentence
of this paragraph into Word, and it stops at the following points ("|" marks a
stop point; the cursor starts at the first "|"):

|Ctrl|+|Left |Arrow|/|Right |Arrow |skip |punctuation|.|

In this text entry field, it stops as follows:

|Ctrl+Left |Arrow/Right |Arrow |skip |punctuation.|



A couple other text editing issues:

1. I just noticed that when I hit Ctrl+Right Arrow at the end of this text entry
field, it acts as if I had hit Ctrl+Home!

2. PgUp/PgDn do not move the cursor, only the view -- so when I then hit one of
the arrow keys, it returns me to where I was!

3. Down Arrow on the last line acts like End when it should do nothing (as
Word); if I then hit Right Arrow, it acts as if I had hit "Home, Right Arrow".

4. I was navigating in this paragraph (before I broke it into numbered
sections), and it DID stop after the "!" at the end of the first sentence in
this paragraph, but not the "." at the end of the previous sentence.

5. I wonder if it stops on a question mark?  Well, it doesn't.  But it DID stop
after the "." after "doesn't"!  And it DID NOT stop after the "!" in the
previous sentence!  (Or the previous.)  Very odd.

6. Finally, Ctrl+Up Arrow and Ctrl+Down Arrow should do something.  Either move
to the previous/next paragraph, or scroll the window, leaving the cursor where
it is (unless the cursor "scrolls off the window" in which case keep it at the
bottom/top line).




I realize that I lumped many bugs together in this report, but they're all
dealing with the text editor.  Another I just noticed now -- 

7. My typing is faster than the screen updating, so I looked at the Windows Task
Manager and it shows that Mozilla takes up the entire processor while I type. 
As soon as I stop typing, usage goes back down to 0%.



Another annoyance: I had entered the above into this form.  Then I went back to
the other Mozilla window to search Bugzilla for "ctrl punctuation" (I had
originally searched for "ctrl left" which opened this window).  I expected the
second search to open a new window as well, but instead it reused this window! 
When I hit "Back" it returned me to this entry form, with the Summary still
filled in but all of this text deleted!  VERY annoying, especially because it
was selective in retaining my data.




Reproducible: Always
Steps to Reproduce:
1. Enter text into a text entry field, including a word containing punctuation
(such as Ctrl+Enter).
2. Use Ctrl+Left Arrow or Ctrl+Right Arrow to move around, and you'll notice
that it skips over the entire word "Ctrl+Enter" instead of stopping just before
the "+" and again just before the "E".


Actual Results:  It skipped the punctuation.

Expected Results:  It should stop at the punctuation, as most other program
which process text do under Windows.

Comment 1

16 years ago
Please file separate reports instead of lumping a bunch of problems into one
bug.  It's hard to keep track of what has been fixed when issues are lumped
together.  But before you do, please download a newer version of Mozilla and
retest them, since I think some of those problems have already been fixed.

I filed bug 143787 for the Bugzilla Helper problem you mentioned.

*** This bug has been marked as a duplicate of 98546 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified.
Status: RESOLVED → VERIFIED

Comment 3

15 years ago
reassign in case bugs are later reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.