Closed Bug 1435926 Opened 4 years ago Closed 4 years ago

NotReadableError regressed to crash in [@ pthread_mutex_lock | mozilla::detail::MutexImpl::lock | mozilla::SourceMediaStream::EndTrack ]

Categories

(Core :: WebRTC: Audio/Video, defect, P2)

60 Branch
Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1435673
Tracking Status
thunderbird_esr52 --- unaffected
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- affected

People

(Reporter: jib, Assigned: pehrsons)

References

Details

(Keywords: regression, reproducible)

Crash Data

STRs:
 1. Get Mac into a state where the camera doesn't work anymore.
    (I'm running OSX 10.12.6 MBP and this happens occasionally after closing and opening lid.
     Photo Booth doesn't work, and Chrome and Firefox 57-59 both return NotReadableError.
     I have to use "sudo killall VDCAssistant" to get out of this mode.)

 2. Open https://webrtc.github.io/samples/src/content/peerconnection/pc1/
 3. Hit [Start] button and Allow cam+mic.

Expected result:
  getUserMedia() error: NotReadableError

Actual result:
  bp-d098756a-9722-401b-b10b-c22d90180206
  bp-a9192946-2eba-4bee-a08b-537150180206

Regression range:

13:33.47 INFO: No more inbound revisions, bisection finished.
13:33.47 INFO: Last good revision: 3018e377678c88dd85fd6dec8bda445a9e894141
13:33.47 INFO: First bad revision: 93a8b769cb7a76aa8eb1c0b182c84d5bdf2fcb71
13:33.47 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3018e377678c88dd85fd6dec8bda445a9e894141&tochange=93a8b769cb7a76aa8eb1c0b182c84d5bdf2fcb71
Thanks, we have track of this one, although this signature for crash-stats was new.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1435673
You need to log in before you can comment on or make changes to this bug.