Closed Bug 1436519 Opened 2 years ago Closed 2 years ago

Crash in nsDeviceContext::UnregisterPageDoneCallback

Categories

(Core :: Printing: Output, defect)

59 Branch
All
Windows
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1435495
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- fix-optional
firefox60 --- fix-optional

People

(Reporter: philipp, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-1c22aa1a-1650-46ce-940d-a77970180207.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll nsDeviceContext::UnregisterPageDoneCallback gfx/src/nsDeviceContext.cpp:748
1 xul.dll nsPrintJob::DonePrintingPages layout/printing/nsPrintJob.cpp:3089
2 xul.dll nsPrintJob::DocumentReadyForPrinting layout/printing/nsPrintJob.cpp:1579
3 xul.dll nsPrintJob::FinishPrintPreview layout/printing/nsPrintJob.cpp:3438
4 xul.dll nsPrintJob::AfterNetworkPrint layout/printing/nsPrintJob.cpp:2042
5 xul.dll nsPrintJob::OnStateChange layout/printing/nsPrintJob.cpp:2077
6 xul.dll nsDocLoader::DoFireOnStateChange uriloader/base/nsDocLoader.cpp:1319
7 xul.dll nsDocLoader::FireOnStateChange uriloader/base/nsDocLoader.cpp:1282
8 xul.dll nsDocLoader::OnStopRequest uriloader/base/nsDocLoader.cpp:615
9 xul.dll mozilla::net::nsLoadGroup::RemoveRequest netwerk/base/nsLoadGroup.cpp:629

=============================================================

this crash signature is newly showing up on 59, so far only on windows and from the content process most of the time.
Dup of bug 1435495. See 1435495 comment 9.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1435495
You need to log in before you can comment on or make changes to this bug.