Closed Bug 1436588 Opened 2 years ago Closed 2 years ago

[wpt-sync] PR 9373 - [css-fonts-4] Contribute Microsoft tests for Font Variations

Categories

(Core :: Layout: Text and Fonts, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: wptsync, Unassigned)

Details

(Whiteboard: [wptsync downstream])

Contributing (most) of our own CSS Fonts 4 tests to web-platform-tests. Some tests have not been ported because they require Microsoft Windows fonts and I have not enough time/expertise to create a dummy version of these fonts.

**INTEROP:** Chrome, Safari and Firefox all seem to have issues with these tests, so it would be good if someone from either/all of these browsers could review the tests. 

**NOTE:** One of the test requires you to install some fonts natively on your system. These fonts are a new (but backward-compatible) version of the fonts that are already required for other css-fonts tests. I created this new version because the old version didn't give any mean to test font matching via JavaScript, which is annoying. If this PR gets merged, someone should update http://www.w3.org/Style/CSS/Test/Fonts/CSSTest/ but I don't know who to contact.
Component: web-platform-tests → Layout: Text
Product: Testing → Core
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/mozilla-inbound/rev/c071075a3935
[wpt PR 9373] - [css-fonts-4] Contribute Microsoft tests for Font Variations, a=testonly
https://hg.mozilla.org/integration/mozilla-inbound/rev/0465b407f68e
[wpt PR 9373] - Update wpt metadata, a=testonly
https://hg.mozilla.org/mozilla-central/rev/c071075a3935
https://hg.mozilla.org/mozilla-central/rev/0465b407f68e
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.