Gloda bar chart not working - Gloda produces heaps of errors in the error console

RESOLVED FIXED in Thunderbird 60.0

Status

defect
RESOLVED FIXED
Last year
Last year

People

(Reporter: jorgk, Assigned: jorgk)

Tracking

({regression})

Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird59 fixed, thunderbird60 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

Last year
+++ This bug was initially created as a clone of Bug #1436290 +++

While working on bug 1436290 I noticed that Gloda search produces heaps of errors in the error console, already at 59.0a1 (2018-01-19) (64-bit).

pv is not defined  glodaFacetVis.js:62
TypeError: this.hotBars is undefined glodaFacetVis.js:336:5
TypeError: this.hotBars is undefined glodaFacetVis.js:336:5
ReferenceError: pv is not defined glodaFacetVis.js:62:9
TypeError: this.emptyBins is undefined glodaFacetVis.js:326:9
and more.

STR:
Use global search to look for something that will yield a result.
Open the error console.
Hover the mouse over the items in the result page.

Alice, can you please help us to find the regression.
Flags: needinfo?(alice0775)
Assignee

Comment 2

Last year
I have the impression that this is all a consequence of |pv is not defined glodaFacetVis.js:62|.

Looks like the bar chart is done with
https://dxr.mozilla.org/comm-central/source/mail/base/content/protovis-r2.6-modded.js
and 'pv' is the main variable in that file.

I can't see how this hangs together.
Summary: Gloda produces heaps of errors in the error console → Gloda bar chart not working - Gloda produces heaps of errors in the error console

Comment 3

Last year
Copied 3rd party libraries that only wait for being broken by the JS engine changes in Gecko.
There is a bug for replacing protovis. Of course it would need to rewrite some of our code that uses it.
Assignee

Comment 4

Last year
Aceman, looks like you've already found the bug I wanted you to look at.

Andrew, could you please take a look at the M-C regression range in comment #1 and see whether anything catches your eye. Any other hint you might have would be appreciated.
Flags: needinfo?(bugmail)
Triggered by: Bug 1428745


Removing ";version=1.8" from <script> tag in [1]  will fix the error.

[1]
mail/base/content/glodaFacetView.xhtml
Blocks: 1428745
Assignee

Comment 6

Last year
Thanks, Alice!! I saw that bug and was looking for a version tag but missed the Xhtml file :-(
Flags: needinfo?(bugmail)
Assignee

Comment 7

Last year
Four left in the tree, one in suite. Killing them all.
Assignee: nobody → jorgk
Status: NEW → ASSIGNED
Attachment #8949546 - Flags: review?(frgrahl)
Attachment #8949546 - Flags: review?(acelists)

Comment 8

Last year
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/36b19d54366f
remove remaining ';version=1.8' from xhtml and xul files (since it's not supported after bug 1428745). rs=bustage-fix
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Assignee

Updated

Last year
Target Milestone: --- → Thunderbird 60.0
Version: 52 → 59
Assignee

Updated

Last year
Attachment #8949546 - Flags: approval-comm-release+
Assignee

Comment 9

Last year
Comment on attachment 8949546 [details] [diff] [review]
1436590-version-removal.patch

[Triage Comment]
Attachment #8949546 - Flags: approval-comm-release+ → approval-comm-beta+

Comment 10

Last year
Comment on attachment 8949546 [details] [diff] [review]
1436590-version-removal.patch

Review of attachment 8949546 [details] [diff] [review]:
-----------------------------------------------------------------

I haven't seen any ill effects from the errors, but the patch does remove those errors.
Thanks.

I think we intentionally left those version=1.8 for the external library as it may be version 1.8 JS. But if it is no longer accepted by JS engine we have to remove the version and fix the library as needed.
Attachment #8949546 - Flags: review?(acelists) → review+
Comment on attachment 8949546 [details] [diff] [review]
1436590-version-removal.patch

Sorry late to game. Thanks+++
Attachment #8949546 - Flags: review?(frgrahl) → review+
You need to log in before you can comment on or make changes to this bug.