Closed Bug 1436713 Opened 2 years ago Closed 2 years ago

Crash in audiounit_enumerate_devices

Categories

(Core :: Audio/Video: cubeb, defect, P3, critical)

Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- wontfix
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- wontfix
firefox61 --- fixed

People

(Reporter: calixte, Assigned: achronop)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-1b276002-9d86-4074-b4e9-45f4e0180206.
=============================================================

Top 10 frames of crashing thread:

0  @0x7fff73b7e7c2 
1 XUL google_breakpad::ReceivePort::WaitForMessage toolkit/crashreporter/google-breakpad/src/common/mac/MachIPC.mm:249
2 XUL google_breakpad::CrashGenerationClient::RequestDumpForException toolkit/crashreporter/breakpad-client/mac/crash_generation/crash_generation_client.cc:67
3 XUL google_breakpad::ExceptionHandler::WriteMinidumpWithException toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:375
4 XUL google_breakpad::ExceptionHandler::SignalHandler toolkit/crashreporter/breakpad-client/mac/handler/exception_handler.cc:616
5  @0x7fff73cb9f59 
6  @0x5cbf 
7  @0x7fff73ae4311 
8  @0x7fff73aac367 
9 XUL audiounit_enumerate_devices media/libcubeb/src/cubeb_audiounit.cpp:3207

=============================================================

There is 1 crash in nightly 60 with buildid 20180204220351. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1435307.

[1] https://hg.mozilla.org/mozilla-central/rev?node=4b03038db310
Flags: needinfo?(achronop)
Stack is busted unfortunately.
Rank: 25
Priority: -- → P3
There are 21 crashes in beta 60, maybe one of them has a good stack.
Duplicate of this bug: 1451541
My Developer Edition just posted bp-8e4289de-4a09-40da-93a7-124d20180417 which is apparently this.

Triggering incident was unplugging a USB headset. I did have Jive's web client open in a tab (which intriguingly was not one of the tabs that crashed - all my Gmail tabs crashed though).
Looks similar to bug 1433384 - should Developer Edition build 20180409184545 have picked that up yet?
I just hit this in Nightly 2018-04-24 when unplugging my USB headset after a Vidyo call.  The crashing process included Gmail tabs.

https://crash-stats.mozilla.com/report/index/86c0b2cf-0e6d-4967-b70c-be30e0180424
I have landed a fix with Bug 1458199, which I am expecting to clear that issue too. The conditions that make this problem appears are vague and I cannot say for sure whether it is fixed or not. However, the results in crash report are encouraging. I will leave it open for some more days and keep an eye on it. For those reported in the bug please say something if you have it again on a latest Nightly or Beta (fix made it before the merge).
I am closing that now, feel free to reopen if you have it again.
Status: NEW → RESOLVED
Closed: 2 years ago
Depends on: 1458199
Flags: needinfo?(achronop)
Resolution: --- → FIXED
Assignee: nobody → achronop
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.