Closed Bug 1437106 Opened 2 years ago Closed 4 months ago

Assertion failure: mDocument->GetReadyStateEnum() == nsIDocument::READYSTATE_INTERACTIVE (Bad readyState), at /src/dom/xslt/xslt/txMozillaTextOutput.cpp:91

Categories

(Core :: XSLT, defect, P3)

60 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1405416
Tracking Status
firefox60 --- affected
firefox61 --- affected

People

(Reporter: tsmith, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: assertion, testcase)

Attachments

(1 file)

Attached file testcase.html
BuildID=20180209100327
SourceStamp=d49553765a743ebbd4f08e92a93c9d811ee064c2

Assertion failure: mDocument->GetReadyStateEnum() == nsIDocument::READYSTATE_INTERACTIVE (Bad readyState), at /src/dom/xslt/xslt/txMozillaTextOutput.cpp:91

#0 in txMozillaTextOutput::endDocument(nsresult) /src/dom/xslt/xslt/txMozillaTextOutput.cpp:87:9
#1 in txMozillaXSLTProcessor::TransformToDoc(nsIDocument**, bool) /src/dom/xslt/xslt/txMozillaXSLTProcessor.cpp:689:25
#2 in txMozillaXSLTProcessor::TransformToDocument(nsINode&, mozilla::ErrorResult&) /src/dom/xslt/xslt/txMozillaXSLTProcessor.cpp:656:10
#3 in mozilla::dom::XSLTProcessorBinding::transformToDocument(JSContext*, JS::Handle<JSObject*>, txMozillaXSLTProcessor*, JSJitMethodCallArgs const&) /src/obj-firefox/dom/bindings/XSLTProcessorBinding.cpp:177:49
#4 in mozilla::dom::GenericBindingMethod(JSContext*, unsigned int, JS::Value*) /src/dom/bindings/BindingUtils.cpp:3035:13
#5 in js::CallJSNative(JSContext*, bool (*)(JSContext*, unsigned int, JS::Value*), JS::CallArgs const&) /src/js/src/jscntxtinlines.h:291:15
#6 in js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct) /src/js/src/vm/Interpreter.cpp:473:16
#7 in InternalCall(JSContext*, js::AnyInvokeArgs const&) /src/js/src/vm/Interpreter.cpp:522:12
#8 in Interpret(JSContext*, js::RunState&) /src/js/src/vm/Interpreter.cpp:3096:18
#9 in js::RunScript(JSContext*, js::RunState&) /src/js/src/vm/Interpreter.cpp:423:12
#10 in js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct) /src/js/src/vm/Interpreter.cpp:495:15
#11 in InternalCall(JSContext*, js::AnyInvokeArgs const&) /src/js/src/vm/Interpreter.cpp:522:12
#12 in js::Call(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, js::AnyInvokeArgs const&, JS::MutableHandle<JS::Value>) /src/js/src/vm/Interpreter.cpp:541:10
#13 in JS::Call(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JS::HandleValueArray const&, JS::MutableHandle<JS::Value>) /src/js/src/jsapi.cpp:3037:12
#14 in mozilla::dom::EventListener::HandleEvent(JSContext*, JS::Handle<JS::Value>, mozilla::dom::Event&, mozilla::ErrorResult&) /src/obj-firefox/dom/bindings/EventListenerBinding.cpp:47:8
#15 in void mozilla::dom::EventListener::HandleEvent<mozilla::dom::EventTarget*>(mozilla::dom::EventTarget* const&, mozilla::dom::Event&, mozilla::ErrorResult&, char const*, mozilla::dom::CallbackObject::ExceptionHandling, JSCompartment*) /src/obj-firefox/dist/include/mozilla/dom/EventListenerBinding.h:65:12
#16 in mozilla::EventListenerManager::HandleEventSubType(mozilla::EventListenerManager::Listener*, nsIDOMEvent*, mozilla::dom::EventTarget*) /src/dom/events/EventListenerManager.cpp:1108:9
#17 in mozilla::EventListenerManager::HandleEventInternal(nsPresContext*, mozilla::WidgetEvent*, nsIDOMEvent**, mozilla::dom::EventTarget*, nsEventStatus*) /src/dom/events/EventListenerManager.cpp:1286:20
#18 in mozilla::EventTargetChainItem::HandleEvent(mozilla::EventChainPostVisitor&, mozilla::ELMCreationDetector&) /src/dom/events/EventDispatcher.cpp:337:17
#19 in mozilla::EventTargetChainItem::HandleEventTargetChain(nsTArray<mozilla::EventTargetChainItem>&, mozilla::EventChainPostVisitor&, mozilla::EventDispatchingCallback*, mozilla::ELMCreationDetector&) /src/dom/events/EventDispatcher.cpp:514:14
#20 in mozilla::EventDispatcher::Dispatch(nsISupports*, nsPresContext*, mozilla::WidgetEvent*, nsIDOMEvent*, nsEventStatus*, mozilla::EventDispatchingCallback*, nsTArray<mozilla::dom::EventTarget*>*) /src/dom/events/EventDispatcher.cpp:859:9
#21 in mozilla::EventDispatcher::DispatchDOMEvent(nsISupports*, mozilla::WidgetEvent*, nsIDOMEvent*, nsPresContext*, nsEventStatus*) /src/dom/events/EventDispatcher.cpp:926:12
#22 in nsINode::DispatchEvent(nsIDOMEvent*, bool*) /src/dom/base/nsINode.cpp:1275:5
#23 in nsContentUtils::DispatchEvent(nsIDocument*, nsISupports*, nsTSubstring<char16_t> const&, bool, bool, bool, bool*, bool) /src/dom/base/nsContentUtils.cpp:4534:18
#24 in nsContentUtils::DispatchTrustedEvent(nsIDocument*, nsISupports*, nsTSubstring<char16_t> const&, bool, bool, bool*) /src/dom/base/nsContentUtils.cpp:4502:10
#25 in nsDocument::DispatchContentLoadedEvents() /src/dom/base/nsDocument.cpp:5376:3
#26 in mozilla::detail::RunnableMethodImpl<nsDocument*, void (nsDocument::*)(), true, (mozilla::RunnableKind)0>::Run() /src/obj-firefox/dist/include/nsThreadUtils.h:1200:13
#27 in nsThread::ProcessNextEvent(bool, bool*) /src/xpcom/threads/nsThread.cpp:1040:14
#28 in NS_ProcessNextEvent(nsIThread*, bool) /src/xpcom/threads/nsThreadUtils.cpp:517:10
#29 in mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) /src/ipc/glue/MessagePump.cpp:97:21
#30 in MessageLoop::RunInternal() /src/ipc/chromium/src/base/message_loop.cc:326:10
#31 in MessageLoop::Run() /src/ipc/chromium/src/base/message_loop.cc:299:3
#32 in nsBaseAppShell::Run() /src/widget/nsBaseAppShell.cpp:157:27
#33 in nsAppStartup::Run() /src/toolkit/components/startup/nsAppStartup.cpp:288:30
#34 in XREMain::XRE_mainRun() /src/toolkit/xre/nsAppRunner.cpp:4673:22
#35 in XREMain::XRE_main(int, char**, mozilla::BootstrapConfig const&) /src/toolkit/xre/nsAppRunner.cpp:4808:8
#36 in XRE_main(int, char**, mozilla::BootstrapConfig const&) /src/toolkit/xre/nsAppRunner.cpp:4900:21
#37 in do_main(int, char**, char**) /src/browser/app/nsBrowserApp.cpp:231:22
#38 in main /src/browser/app/nsBrowserApp.cpp:304:16
#39 in __libc_start_main /build/glibc-Cl5G7W/glibc-2.23/csu/../csu/libc-start.c:291
#40 in _start (firefox+0x423444)
Flags: in-testsuite?
Peter, seems you touched this file last (when not counting Kyle and Jonas).
Flags: needinfo?(peterv)
Priority: -- → P3
Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(peterv)
Resolution: --- → DUPLICATE
Duplicate of bug: 1405416
You need to log in before you can comment on or make changes to this bug.