Closed Bug 1437477 Opened 5 years ago Closed 3 years ago

Crash in [@ IPCError-browser | ShutDownKill]. After updating Nightly and restarting it.

Categories

(Core :: XPCOM, defect)

x86_64
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox60 --- affected

People

(Reporter: anton.kochkov, Unassigned)

References

(Blocks 1 open bug)

Details

Crash Data

This bug was filed from the Socorro interface and is
report bp-cd562c86-ced3-4fad-8038-3f7c90180212.
=============================================================

Top 10 frames of crashing thread:

0 xul.dll nsPurpleBuffer::VisitEntries<SnowWhiteKiller> xpcom/base/nsCycleCollector.cpp:1125
1 xul.dll nsCycleCollector::FreeSnowWhite xpcom/base/nsCycleCollector.cpp:2911
2 xul.dll AsyncFreeSnowWhite::Run js/xpconnect/src/XPCJSRuntime.cpp:126
3 xul.dll IdleRunnableWrapper::Run xpcom/threads/nsThreadUtils.cpp:343
4 xul.dll IdleRunnableWrapper::TimedOut xpcom/threads/nsThreadUtils.cpp:351
5 xul.dll nsTimerImpl::Fire xpcom/threads/nsTimerImpl.cpp:701
6 xul.dll nsTimerEvent::Run xpcom/threads/TimerThread.cpp:286
7 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1040
8 xul.dll mozilla::ipc::MessagePump::Run ipc/glue/MessagePump.cpp:97
9 xul.dll mozilla::ipc::MessagePumpForChildProcess::Run ipc/glue/MessagePump.cpp:301

=============================================================

After updating the Nightly and restarting it.
Status: UNCONFIRMED → NEW
Component: Untriaged → XPCOM
Ever confirmed: true
Product: Firefox → Core
Summary: Crash in IPCError-browser | ShutDownKill → Crash in [@ IPCError-browser | ShutDownKill]. After updating Nightly and restarting it.
This has happened with "beta" updates for the past month or so, EVERY SINGLE TIME. 

Currently on:
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0 ID:20180607135512


Furthermore, without any working SESSION MANAGER, I have to save all my tabs EVERY SINGLE TIME I want to update.

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.