Closed Bug 1437486 Opened 4 years ago Closed 4 years ago

Forget about site no longer clears anything but 5 minute intervals on Nightly

Categories

(Firefox :: General, defect)

defect
Not set
critical

Tracking

()

RESOLVED FIXED
Firefox 60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

(Keywords: regression)

Attachments

(1 file)

Before bug 1167238, the forget button's code looked like this:


>      this._sanitizer.range = this._getSanitizeRange(doc);

      let group = doc.getElementById("PanelUI-panic-timeSpan");
      BrowserUITelemetry.countPanicEvent(group.selectedItem.id);

>      group.selectedItem = doc.getElementById("PanelUI-panic-5min");

      let itemsToClear = [
        "cookies", "history", "openWindows", "formdata", "sessions", "cache", "downloads"
      ];
      let newWindowPrivateState = PrivateBrowsingUtils.isWindowPrivate(doc.defaultView) ?
                                  "private" : "non-private";
      this._sanitizer.items.openWindows.privateStateForNewWindow = newWindowPrivateState;

>      let promise = this._sanitizer.sanitize(itemsToClear);

Note especially the highlighted lines.

Now it looks like this:

      let group = doc.getElementById("PanelUI-panic-timeSpan");
      BrowserUITelemetry.countPanicEvent(group.selectedItem.id);

>      group.selectedItem = doc.getElementById("PanelUI-panic-5min");

      let itemsToClear = [
        "cookies", "history", "openWindows", "formdata", "sessions", "cache", "downloads"
      ];
      let newWindowPrivateState = PrivateBrowsingUtils.isWindowPrivate(doc.defaultView) ?
                                  "private" : "non-private";

>      let promise = Sanitizer.sanitize(itemsToClear, {
>        ignoreTimespan: false,
>        range: Sanitizer.getClearRange(+group.value),
>        privateStateForNewWindow: newWindowPrivateState,
>      });


This is clearly wrong, and will lead to us always forgetting only 5 minutes.
Flags: needinfo?(jhofmann)
Because I got pinged in bug 1323614 and we can fix both in one go, I'll just put up a patch here.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Blocks: 1323614
Comment on attachment 8950174 [details]
Bug 1437486 - don't reset the forget button duration when the popup is visible,

https://reviewboard.mozilla.org/r/219440/#review225196

Thanks for catching this!
Attachment #8950174 - Flags: review?(jhofmann) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/30f89b1eab1c
don't reset the forget button duration when the popup is visible, r=johannh
https://hg.mozilla.org/mozilla-central/rev/30f89b1eab1c
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
You need to log in before you can comment on or make changes to this bug.