Closed Bug 1437571 Opened 2 years ago Closed 2 years ago

Upgrade winreg dependency

Categories

(Testing :: Mozbase Rust, enhancement)

Version 3
enhancement
Not set

Tracking

(firefox60 fixed)

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: ato, Assigned: ato)

References

Details

Attachments

(2 files)

mozrunner is currently on winreg v0.3.4 but the latest version is v0.5.0.
Blocks: 1401129
Assignee: nobody → ato
Status: NEW → ASSIGNED
One thing I’m a bit uncertain about regardnig this change is that
it adds ~135k lines.  I’m sure the improvements are for the better,
but this presumably also means we need to compile a lot more things.
Since the current code is functioning as intended, I’m fine with
an r- on this patch.
Comment on attachment 8950260 [details]
Bug 1437571 - Upgrade to winreg v0.5.0.

https://reviewboard.mozilla.org/r/219518/#review226006
Attachment #8950260 - Flags: review?(james) → review+
Comment on attachment 8950261 [details]
Bug 1437571 - Bump winreg dependencies.

https://reviewboard.mozilla.org/r/219520/#review226008

Still is impossible to review :p I assume this was just the result of the vendor command.
Attachment #8950261 - Flags: review?(james) → review+
It looks like with winapi 0.3 you can pick what features you want to
include. winreg only picks a couple of these [1] so this should be
safe to land.

I also compared the average build times on TC with this patch
applied, and couldn’t see any significant change.

  [1] https://github.com/gentoo90/winreg-rs/blob/master/Cargo.toml#L13
https://hg.mozilla.org/mozilla-central/rev/8920ee351e02
https://hg.mozilla.org/mozilla-central/rev/f9b1a56d918b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.