Cursor sometimes fails to appear in input text fields

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
P3
normal
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Axel Boldt, Assigned: kinmoz)

Tracking

({embed, topembed-})

Trunk
Future
x86
Windows XP
embed, topembed-
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc2)
Gecko/20020510
BuildID:    2002051006

In the page http://www.google.com/advanced_search
you will find a sequence of four text input fields.
If you click into the first one, the blinking cursor does
not appear (even though it is possible to enter text).
If you click into the second field, the cursor appears.
If you then click into the first field, the cursor
will appear.

This might be a javascript issue since Google does some
Javascript trickery. IE 6.0 shows all cursors properly.
I couldn't find any other page with
text input fields which shows this faulty behavior.

Reproducible: Always

Comment 1

16 years ago
tested with 2002050908
(i'll say is topemebd be cause of google)

is there and is confusing. you can type though, the text appears but is not
obvious. i saw this before but was hard to reproduce. on googles page is there
100% but only the first time. 
Assignee: alexsavulov → rods
Severity: minor → normal
Status: UNCONFIRMED → NEW
Component: Form Submission → HTML Form Controls
Ever confirmed: true
Keywords: topembed
QA Contact: vladimire → tpreston
Reassigning to Kin.
Assignee: rods → kin

Updated

16 years ago
Keywords: topembed → embed, topembed-

Comment 3

16 years ago
I also see this occur randomly....there are no steps to be able to reproduce it
consistently.  I will launch Mozilla, and go to Yahoo! Mail and will not have a
cursor to enter my username and password.  This also occurs on a couple of other
sites that I use.  In fact, I have seen this problem since pre 0.9.5.  The only
way to get the cursor in a text box is by shutting down Moz and restarting.  I
am using WinXP with 512MB ram.

Comment 4

15 years ago
I don't see this bug at google.com with build 2002091016 on Linux.
But when an input field's text is right-aligned, the cursor definitely is
missing (until you start typing).

Comment 5

15 years ago
Created attachment 99639 [details]
testcase
WFM: Using 2003020604 build on WinXP.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Priority: -- → P3
Resolution: --- → WORKSFORME
Target Milestone: --- → Future
You need to log in before you can comment on or make changes to this bug.