Android bootstrap fails with java9 (android's fault)

RESOLVED DUPLICATE of bug 1477487

Status

defect
RESOLVED DUPLICATE of bug 1477487
Last year
5 months ago

People

(Reporter: sylvestre, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox60 affected)

Details

Not our fault but I report a bug to help potential folks having the same issue.

$ /home/sylvestre/.mozbuild/android-sdk-linux/tools/bin/sdkmanager --package_file=/home/sylvestre/dev/mozilla/mozilla-inbound/python/mozboot/mozboot/android-packages.txt
Exception in thread "main" java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema
	at com.android.repository.api.SchemaModule$SchemaModuleVersion.<init>(SchemaModule.java:156)
	at com.android.repository.api.SchemaModule.<init>(SchemaModule.java:75)
	at com.android.sdklib.repository.AndroidSdkHandler.<clinit>(AndroidSdkHandler.java:81)
	at com.android.sdklib.tool.SdkManagerCli.main(SdkManagerCli.java:117)
	at com.android.sdklib.tool.SdkManagerCli.main(SdkManagerCli.java:93)
Caused by: java.lang.ClassNotFoundException: javax.xml.bind.annotation.XmlSchema
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:185)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
	... 5 more

$  java --version
openjdk 9.0.1
OpenJDK Runtime Environment (build 9.0.1+11-Debian-1)
OpenJDK 64-Bit Server VM (build 9.0.1+11-Debian-1, mixed mode)


Reverting to java 8 fixed the issue.

Updated

Last year
Product: Core → Firefox Build System
Component: General → Bootstrap Configuration

I believe that this has been addressed by Bug 1477487.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1477487
You need to log in before you can comment on or make changes to this bug.