Add bool field to indicate whether direction was specified to RustSdpAttributeExtmap

RESOLVED FIXED in Firefox 63

Status

()

enhancement
P2
normal
Rank:
15
RESOLVED FIXED
a year ago
9 months ago

People

(Reporter: dminor, Assigned: johannes.willbold)

Tracking

(Blocks 1 bug)

60 Branch
mozilla63
Points:
---

Firefox Tracking Flags

(firefox60 wontfix, firefox61 wontfix, firefox62 wontfix, firefox63 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
In rsdparsa this is already an Option<>, so we probably just need to add a bool to the RustSdpAttributeExtmap structure and set it accordingly in rsdparsa_capi.
(Reporter)

Updated

a year ago
See Also: → 1438544

Updated

10 months ago
Assignee: nobody → johannes.willbold
Rank: 15
Priority: P3 → P2
Comment hidden (mozreview-request)

Comment 2

10 months ago
mozreview-review
Comment on attachment 8991351 [details]
Bug 1438536: Added bool field to indicate whether direction was specified to RustSdpAttributeExtmap,

https://reviewboard.mozilla.org/r/256254/#review263188

::: media/webrtc/signaling/src/sdp/RsdparsaSdpInc.h:233
(Diff revision 1)
>  // TODO: Add field indicating whether direction was specified
>  // See Bug 1438536.

I think this comment should be removed now.
Attachment #8991351 - Flags: review?(drno) → review+
Comment hidden (mozreview-request)

Comment 4

10 months ago
Pushed by drno@ohlmeier.org:
https://hg.mozilla.org/integration/autoland/rev/6e1745b030b8
Added bool field to indicate whether direction was specified to RustSdpAttributeExtmap, r=drno

Comment 5

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6e1745b030b8
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
(Assignee)

Updated

10 months ago
Duplicate of this bug: 1438544
You need to log in before you can comment on or make changes to this bug.