Closed Bug 1438547 Opened 3 years ago Closed 2 years ago

Crash in libhwui.so@0x8249e (OnePlus One devices)

Categories

(Firefox for Android Graveyard :: General, defect)

Firefox 59
All
Android
defect
Not set
critical

Tracking

(fennec?, firefox58 affected, firefox59 affected, firefox60 affected)

RESOLVED WORKSFORME
Tracking Status
fennec ? ---
firefox58 --- affected
firefox59 --- affected
firefox60 --- affected

People

(Reporter: marcia, Unassigned, NeedInfo)

Details

(Keywords: crash)

Crash Data

This bug was filed from the Socorro interface and is
report bp-7189e340-563d-4c3d-9747-bab670180215.
=============================================================

Seen while looking at release crash stats: http://bit.ly/2EuzKuX. Crashes appear to be confined to API 26 and One Plus One devices. 59 and 60 are affected but in small volume. 

Unsure if we have a device to try to reproduce on.


Top 10 frames of crashing thread:

0 libc.so libc.so@0x4b10c 
1 libhwui.so libhwui.so@0x8249e 
2 libhwui.so libhwui.so@0x8249e 
3 libhwui.so libhwui.so@0x8c382 
4 liblog.so liblog.so@0x684b 
5 libhwui.so libhwui.so@0x83270 
6 liblog.so liblog.so@0x6866 
7 boot-framework.oat boot-framework.oat@0x11ae270 
8 dalvik-main space (region space) (deleted) dalvik-main space @0x1cb36267 
9 system@framework@boot-framework.art system@framework@boot-framework.art@0x282463 

=============================================================
Here are the affected devices:

oneplus 	ONEPLUS A5000 	26 (REL) 	armeabi-v7a 	130 	42.3%
oneplus 	ONEPLUS A5010 	26 (REL) 	armeabi-v7a 	77 	25.1%
oneplus 	ONEPLUS A3003 	26 (REL) 	armeabi-v7a 	72 	23.5%
oneplus 	ONEPLUS A3000 	26 (REL) 	armeabi-v7a 	24 	7.8%
oneplus 	ONEPLUS A3010 	26 (REL) 	armeabi-v7a 	4 	1.3%
Summary: Crash in libhwui.so@0x8249e (One Plus One devices) → Crash in libhwui.so@0x8249e (OnePlus One devices)
Forgot to mention this is #24 overall browser crash on Fennec release.
Adding ni on Ioana since this was discussed in yesterday's Channel meeting.
Flags: needinfo?(ioana.chiorean)
tracking-fennec: --- → ?
Hardware: Unspecified → All
Hi Marcia,
We have ONEPLUS A3000. I am gonna spend more time on it. From crash comments I see:
- just opened a tab and this popped up.
- crashed when alarm went off.
- Was streaming Twitch and it crashed.
Currently this is #16 top browser crash on Fennec release.

Very trivial volume on both 65 and 66. Not really worth keeping this open, so I am resolving this one was WFM.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.