Closed Bug 1438554 Opened 3 years ago Closed 3 years ago

[Mac] Crash in webrtc::videocapturemodule::VideoCaptureImpl::IncomingFrame

Categories

(Core :: WebRTC: Audio/Video, defect, P2)

Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- fixed

People

(Reporter: marcia, Assigned: dminor)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-1287ad6a-e867-4447-bfd2-5c4f60180215.
=============================================================

Seen while looking at Mac nightly crash stats - small volume Mac crash hit by several unique users: http://bit.ly/2EsWF5I. Crash reason for all crashes is EXC_BAD_ACCESS / EXC_I386_GPFLT. Affects 10.11-10.13. Seen starting in 20180126104626 build.

Top 10 frames of crashing thread:

0 XUL webrtc::videocapturemodule::VideoCaptureImpl::IncomingFrame media/webrtc/trunk/webrtc/modules/video_capture/video_capture_impl.cc:135
1 XUL -[RTCVideoCaptureIosObjC captureOutput:didOutputSampleBuffer:fromConnection:] media/webrtc/trunk/webrtc/modules/video_capture/objc/rtc_video_capture_objc.mm:364
2 AVFoundation __ConsumerRender_block_invoke 
3 libdispatch.dylib _dispatch_call_block_and_release 
4 libdispatch.dylib _dispatch_client_callout 
5 libdispatch.dylib _dispatch_root_queue_drain 
6 libdispatch.dylib _dispatch_worker_thread3 
7 libsystem_pthread.dylib _pthread_wqthread 
8 libsystem_pthread.dylib start_wqthread 
9 libdispatch.dylib dispatch_source_set_cancel_handler 

=============================================================
This was likely caused by the build system changes in Bug 1393119, which accidentally caused us to start using a newer version of the OS X video capture code. I'm not sure at this point if we're going to revert to using an older version or continue with the newer version and fix the problems that have shown up. Long term, we want to use the new stuff.
Blocks: 1393119
Rank: 15
Component: WebRTC → WebRTC: Audio/Video
Priority: -- → P2
See Also: → 1436959
Fix optional for 60 per triage team, will revaluate if numbers increase.
This should be fixed by the patches on Bug 1436959. It hasn't shown up since that landed, but it was pretty low frequency before, so it's hard to be completely certain it is actually fixed.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Assignee: nobody → dminor
Depends on: 1436959
Target Milestone: --- → mozilla60
See Also: → 1515461
You need to log in before you can comment on or make changes to this bug.