Google Pinyin IME duplicates text after switching focus

VERIFIED FIXED in Firefox 59

Status

()

defect
VERIFIED FIXED
2 years ago
Last year

People

(Reporter: jchen, Assigned: jchen)

Tracking

Trunk
Firefox 60
All
Android
Points:
---

Firefox Tracking Flags

(fennec+, firefox58 wontfix, firefox59 verified, firefox60 fixed)

Details

Attachments

(2 attachments)

1. Focus one input using Google Pinyin IME in English mode
2. Focus another input with existing text
3. Type something
4. Existing word is duplicated
Comment on attachment 8951460 [details]
Bug 1438682 - 1. Cache initial selection offsets;

https://reviewboard.mozilla.org/r/220758/#review226852
Attachment #8951460 - Flags: review?(esawin) → review+
Comment on attachment 8951461 [details]
Bug 1438682 - 2. Implement dummy closeConnection;

https://reviewboard.mozilla.org/r/220760/#review226854
Attachment #8951461 - Flags: review?(esawin) → review+
Pushed by nchen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f066f679fb04
1. Cache initial selection offsets; r=esawin
https://hg.mozilla.org/integration/autoland/rev/7ea185f4bce1
2. Implement dummy closeConnection; r=esawin
https://hg.mozilla.org/mozilla-central/rev/f066f679fb04
https://hg.mozilla.org/mozilla-central/rev/7ea185f4bce1
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
tracking-fennec: --- → ?
Comment on attachment 8951460 [details]
Bug 1438682 - 1. Cache initial selection offsets;

We should consider uplifting this because it's a really annoying bug.

Approval Request Comment
[Feature/Bug causing the regression]: N/A
[User impact if declined]: Annoying bug when using some keyboards, resulting in duplicated text when entering text.
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: Not really.
[Why is the change risky/not risky?]: Small change to fix the bug.
[String changes made/needed]: None
Attachment #8951460 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Comment on attachment 8951460 [details]
Bug 1438682 - 1. Cache initial selection offsets;

OK, let's uplift this for beta 12 (effectively, for the beta 13 mobile build) an verify in beta instead of in nightly.
Attachment #8951460 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #8951461 - Flags: approval-mozilla-beta+
tracking-fennec: ? → +
Verified as fixed on Beta 59.0b13
HTC 10 (Android 8.0)
Status: RESOLVED → VERIFIED
Remove qe-verify flag based on comment 10.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.