Closed Bug 1438892 Opened 2 years ago Closed 2 years ago

Update webrender to e8d2ffb404a85651fe08a6d09abbece9bd2b9182

Categories

(Core :: Graphics: WebRender, enhancement, P3)

60 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox60 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Whiteboard: [gfx-noted])

Attachments

(7 files)

+++ This bug was initially created as a clone of Bug #1437572 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ 1a7bda5a12236f1ea727ae748d604e2e2a56b0bf, this time with rayon patch for webrender_bindings that glenn provided on bug 1437572.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=210015507bc6ffb914673697748b975fff5439f5
https://treeherder.mozilla.org/#/jobs?repo=try&revision=6acc361bd7ccae3eafed17ae6a5a57d77033e014

R4 reftest failures, but they're nondeterministic. I retriggered a few times and get slightly difference results. In all cases a subset of the following tests are failing with fuzz(14,8):

layout/reftests/css-invalid/input/input-radio-required.html
layout/reftests/css-invalid/input/input-radio-customerror.html
layout/reftests/css-invalid/input/input-radio-dyn-valid-1.html
layout/reftests/css-invalid/input/input-radio-dyn-valid-2.html
layout/reftests/css-invalid/input/input-radio-nogroup-required-valid.html
layout/reftests/css-invalid/input/input-radio-nogroup-required-invalid.html
layout/reftests/css-invalid/input/input-radio-focus-click.html

While I could just mark them fuzzy-if(webrender,0-14,0-8) it might be worth investigating why we get correct rendering sometimes and fuzzy at other times. ni? Gankro since this is likely coming from servo/webrender#2405.
Flags: needinfo?(a.beingessner)
I also did WR @ b711201fe2ae4ab1ee7a1dc4a055dc3d90c0ca05

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b67d5427f13347a6b171739048cab5e5a942b965
https://treeherder.mozilla.org/#/jobs?repo=try&revision=109bc2f016852a5ba377f5d42f48d04b06ebec75

This is showing shader compilation failures on Windows, at https://treeherder.mozilla.org/logviewer.html#?job_id=162670488&repo=try&lineNumber=1827

Regression range for that is:

*   b711201f Auto merge of #2430 - eeejay:colormatrix-column-order, r=glennw
|\
| * fd7d6a63 Change color matrix format to column order to better match internal data types.
*   003ec399 Auto merge of #2426 - glennw:gradient-repeat, r=nical
|\
| * db29b9a3 Remove discard from radial gradient, apply tile/repeat on CPU.
* 92919103 Auto merge of #2424 - glennw:yuv-brush, r=kvark
* e6dc591c Port YUV primitive to be a brush.

So almost certainly from github/servo#2424.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> So almost certainly from github/servo#2424.

I meant servo/webrender#2424
WR @ ea864205ae2c9791a37b2ccc79173ea41d146c50, with a wide enough fuzz range to cover all the nondeterministic stuff from comment 1.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=ed293b30cdb169b4004ce56b0b4ea4fefd57bab5
https://treeherder.mozilla.org/#/jobs?repo=try&revision=8ee19a65932b1d1f2bde6452f79d02a1e660cfa4

No new problems. There's R4 unexpected passes which came from servo/webrender#2426 and I forgot to annotate before. Will do that now.
WR @ d7c26b610688a430fbee98d7ef029d588cc1cd2c

https://treeherder.mozilla.org/#/jobs?repo=try&revision=f9b26e9f27099040e270c51c872f774d137989e9
https://treeherder.mozilla.org/#/jobs?repo=try&revision=40e144ad2b4858097323a9d18bc48744866a28ba
https://treeherder.mozilla.org/#/jobs?repo=try&revision=fdbff31facbd66c7d7d3a54c392a17c744e18705
https://treeherder.mozilla.org/#/jobs?repo=try&revision=c7d1d55c3480bdd2355e3d9f6d069ff88be08188
https://treeherder.mozilla.org/#/jobs?repo=try&revision=7650fafc5a0557d4ddcd68ac32d57855bda07d55
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ad0c801ce50df6f0ee579a9153edc462224b43b3
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e03972f137989eb3df6e3563cd712b1584b6f8a7
https://treeherder.mozilla.org/#/jobs?repo=try&revision=9d1f5b7aa557570bfdc14574b6c7e2c1c01a0005
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e20c37349dcfe122775a9b056ad880b8018ab2f7
https://treeherder.mozilla.org/#/jobs?repo=try&revision=d6ac074c142bee5c39351a1a6d8e3021e784bf37
https://treeherder.mozilla.org/#/jobs?repo=try&revision=164da73f03dab67d56d867660a7a3c03cb1e3c6a
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a0cbefe32e7f429d67d340e5a17938b25c2d8f82

Some R3 changes from servo/webrender#2423. Shader compilation failures fixed too.

WR @ 196b9bf99e32ddbf3e74d9bbc5fdc918fbcdabc1

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d0010ef733809a1fe746591e7e93ec22b248ded3
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2da0d3c64e79399e222fc2686e781ae36d680cf5

No new problems

WR @ e8d2ffb404a85651fe08a6d09abbece9bd2b9182

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b38161d7c8e147cb1d75b2b82d5c5c2112a63ebb
https://treeherder.mozilla.org/#/jobs?repo=try&revision=248b82fb135429862c49f24442c42f3b20c86836

Bustage from servo/webrender#2435. Fixed it locally
Blocks: 1439327
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to e8d2ffb404a85651fe08a6d09abbece9bd2b9182
Version: unspecified → 60 Branch
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> ni? Gankro since this is likely coming from servo/webrender#2405.

Spun this out into bug 1439571
Flags: needinfo?(a.beingessner)
Comment on attachment 8952361 [details]
Bug 1438892 - Update Cargo lockfiles and re-vendor rust dependencies.

https://reviewboard.mozilla.org/r/221616/#review227512
Attachment #8952361 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8952362 [details]
Bug 1438892 - Update rayon usage in webrender_bindings for version bump in WR PR 2431.

https://reviewboard.mozilla.org/r/221618/#review227514
Attachment #8952362 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8952363 [details]
Bug 1438892 - Update reftest fuzziness for WR PR 2405.

https://reviewboard.mozilla.org/r/221620/#review227516
Attachment #8952363 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8952364 [details]
Bug 1438892 - Update annotations from WR PR 2426.

https://reviewboard.mozilla.org/r/221622/#review227518
Attachment #8952364 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8952365 [details]
Bug 1438892 - Update reftest results for changes from WR PR 2423.

https://reviewboard.mozilla.org/r/221624/#review227520
Attachment #8952365 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8952366 [details]
Bug 1438892 - Update bindings for API change in WR PR 2435.

https://reviewboard.mozilla.org/r/221626/#review227522
Attachment #8952366 - Flags: review?(jmuizelaar) → review+
Comment on attachment 8952360 [details]
Bug 1438892 - Update webrender to e8d2ffb404a85651fe08a6d09abbece9bd2b9182.

https://reviewboard.mozilla.org/r/221614/#review227510
Attachment #8952360 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b1107be0b74
Update webrender to e8d2ffb404a85651fe08a6d09abbece9bd2b9182. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/2f0342644d57
Update Cargo lockfiles and re-vendor rust dependencies. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/3327445e7dac
Update rayon usage in webrender_bindings for version bump in WR PR 2431. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/01b824331acd
Update reftest fuzziness for WR PR 2405. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/abdec0a84138
Update annotations from WR PR 2426. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/6af5eb37f1e4
Update reftest results for changes from WR PR 2423. r=jrmuizel
https://hg.mozilla.org/integration/autoland/rev/7819788b6f09
Update bindings for API change in WR PR 2435. r=jrmuizel
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #6)
> Green on Linux, but windows infra issues

Doh, that wasn't windows infra issues, it was a typo on my part. Fixed locally.
Depends on: 1440175
with this update came a performance improvement in the microbenchmarks:
== Change summary for alert #11676 (as of Wed, 21 Feb 2018 01:47:04 GMT) ==

Improvements:

  5%  Strings PerfIsUTF8Example3 osx-10-10 opt      8,211.12 -> 7,829.25

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=11676
No idea what that test does, but most likely one of the rust crate updates sped things up somewhere.
You need to log in before you can comment on or make changes to this bug.