Closed Bug 1438907 Opened 5 years ago Closed 5 years ago

Accessibility feature is wrongly disabled in all tabs if the Web Console is closed from the tab where the feature was first enabled

Categories

(DevTools :: Accessibility Tools, defect)

x86
All
defect
Not set
normal

Tracking

(firefox60 affected)

RESOLVED FIXED
Tracking Status
firefox60 --- affected

People

(Reporter: cmuntean, Unassigned)

References

()

Details

Attachments

(1 file)

[Affected versions]:
- Nightly 60.0a1 (2018-02-15) try build 

[Affected Platforms]:
- All Windows
- All Mac
- All Linux

[Prerequisites]:
- Have the latest try build 60.0a1 from (2018-02-15) installed.
- The "Accessibility" option is checked in "Toolbar Options"

[Steps to reproduce]:
1. Open the Nightly try build with the profile from prerequisites.
2. Navigate to any website press the "F12" key and enable Accessibility features.
3. Open a new tab, press the "F12" key and focus the "Accessibility" tab.
4. Return to the tab where you first enabled Accessibility feature and close the Web Console.
5. Navigate to the other tab and observe the Accessibility tab.

[Expected Results]:
- The Accessibility feature is enabled.

[Actual results]:
- The Accessibility feature is disabled.

[Notes]:
- Attached a screen recording with the issue.
Component: Developer Tools → Developer Tools: Accessibility Tools
will be fixed in latest try.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
I have retested this issue on the latest Nightly try build (2018-03-12) and the issue is no longer reproducible. Tested on Windows 7 x64, Mac Os 10.12 and Arch Linux.
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.