Closed Bug 1439023 Opened 2 years ago Closed 1 year ago

Selection of previously entered form history data broken in Nightly when Form Autofill is enabled

Categories

(Toolkit :: Form Autofill, defect, P2)

60 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- wontfix
firefox60 --- wontfix
firefox65 --- wontfix
firefox66 + verified
firefox67 --- verified

People

(Reporter: alberts, Assigned: MattN)

References

()

Details

(Keywords: regression, testcase)

Attachments

(2 files)

Data I have previously entered in similar fields, like my last name, still appears in a dropdown underneath the corresponding input field, but when I make a selection it does not translate into the input field value anymore. Filling out forms, especially email fields became much more tedious again with this bug.
Please see the video attached.

Maybe I have time after the weekend to find a regression range.
(In reply to Albert Scheiner [:alberts] from comment #0)
> Maybe I have time after the weekend to find a regression range.

That would be awesome!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1437791

Un-duping since it seems like the login form issue of bug 1437791 is resolved but this isn't.

Status: RESOLVED → REOPENED
Component: Form Manager → Form Autofill
Priority: -- → P2
Hardware: x86 → All
Resolution: DUPLICATE → ---
Summary: Selection of previously entered form data broken in Nightly → Selection of previously entered form autofill data broken in Nightly
Summary: Selection of previously entered form autofill data broken in Nightly → Selection of previously entered form history data broken in Nightly when Form Autofill is enabled
Status: REOPENED → NEW
Blocks: 1429718

Otherwise the cached value won't be used for filling by satchel and _fillFromAutocompleteRow won't fill a result that isn't a autofill-profile style:
https://searchfox.org/mozilla-central/rev/03ebbdab952409640c6857d835d3040bf6f9e2db/browser/extensions/formautofill/FormAutofillContent.jsm#283,295

Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Keywords: regression
OS: macOS → All

Albert, do you have that test case handy? Once the patch lands I'd love for us to be able to verify the fix and possibly uplift to beta.

Flags: qe-verify+
Flags: needinfo?(albert)
Pushed by mozilla@noorenberghe.ca:
https://hg.mozilla.org/integration/mozilla-inbound/rev/047455dcfc20
Don't reset autocomplete controller state when autofill fell back to form history. r=jaws

(In reply to Liz Henry (:lizzard) (use needinfo) from comment #5)

Albert, do you have that test case handy? Once the patch lands I'd love for us to be able to verify the fix and possibly uplift to beta.

It's in the URL field.

Status: ASSIGNED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Flags: needinfo?(albert)

It is already working for me! Thanks 🙌

Verified on Nightly 67(20190214044118), that the issue is not reproducing, using the attached testcase.

Flags: qe-verify+

Matt, do you want to request beta uplift?

Flags: needinfo?(MattN+bmo)

Let's give it a week or two to bake first. I'll leave the needinfo as a reminder.

Comment on attachment 9042689 [details]
Bug 1439023 - Don't reset autocomplete controller state when autofill fell back to form history. r=jaws

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1429718

User impact if declined

Form history (and saved logins?) won't fill when the field was handled by Form Autofill.

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

Yes

If yes, steps to reproduce

  1. Set browser.search.region = "US" and restart an en-US Firefox.
  2. Use test page at https://codepen.io/scheinercc/full/mXawWz/ which has STR

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

This returns to the previous behaviour for autocomplete popups not from Form Autofill.

String changes made/needed

None

Flags: needinfo?(MattN+bmo)
Attachment #9042689 - Flags: approval-mozilla-beta?

Comment on attachment 9042689 [details]
Bug 1439023 - Don't reset autocomplete controller state when autofill fell back to form history. r=jaws

Fix for form autofill, verified in Nightly.
OK to uplift for beta 11.

Attachment #9042689 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whiteboard: [qa-triaged]
Depends on: 1531443
QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]

Verified on Beta 66(20190228180200), that the issue is not reproducing, using the attached testcase. Tested on Windows 10 x64, MacOS 10.12 and Ubuntu 16.04

QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.