Closed Bug 1439136 Opened 7 years ago Closed 2 years ago

Broken subpixel blending on Amazon with WebRender enabled

Categories

(Core :: Graphics: WebRender, defect, P2)

60 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: linuxhippy, Unassigned)

References

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180217100053

Steps to reproduce:

1. Logged into my amazon.de account


Actual results:

2. the text of the product recommendations (but not elsewhere) was rendered with broken subpixel blending.


Expected results:

results consistent with the "traditional" opengl backend
Component: Untriaged → Graphics: WebRender
Product: Firefox → Core
Attached image amazon_opengl.png
Attached image amazon_webrender.png
System: Fedora 27, Mesa-17.2.4, AMD Kaveri APU 7650k (radeonsi driver):

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD KAVERI (DRM 2.50.0 / 4.15.3-300.fc27.x86_64, LLVM 5.0.0) (0x1313)
    Version: 17.2.4
    Accelerated: yes
    Video memory: 2048MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
Memory info (GL_ATI_meminfo):
    VBO free memory - total: 2047 MB, largest block: 2047 MB
    VBO free aux. memory - total: 2043 MB, largest block: 2043 MB
    Texture free memory - total: 2047 MB, largest block: 2047 MB
    Texture free aux. memory - total: 2043 MB, largest block: 2043 MB
    Renderbuffer free memory - total: 2047 MB, largest block: 2047 MB
Weird. Any chance you can reproduce this Lee?
Flags: needinfo?(lsalzman)
Not able to reproduce this. But the screenshots are bizarre, like the subpixel layout has gone totally bonkers, almost like an endian-swap or other swizzle. Jonathan, ever seen something like elsewhere?
Flags: needinfo?(lsalzman) → needinfo?(jfkthame)
No, that doesn't look quite like anything I recognize. It seems kinda like the text has been overpainted multiple times, maybe with the alpha channel mishandled in some way.... dunno really. Yes, maybe somehow subpixels have been scrambled, though it doesn't quite look like a straightforward endian swap to me.

What's really odd, though, is that it only messes with certain text; the heading in the screenshots looks unaffected. I don't see anything in the styling there that seems particularly weird.
Flags: needinfo?(jfkthame)
I can still reproduce it with the current nightly version on my system - which in the meantime has been updated to:
Linux 4.15.7

Extended renderer info (GLX_MESA_query_renderer):
    Vendor: X.Org (0x1002)
    Device: AMD KAVERI (DRM 2.50.0 / 4.15.7-300.fc27.x86_64, LLVM 5.0.1) (0x1313)
    Version: 17.3.6
    Accelerated: yes
    Video memory: 1024MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 4.5
    Max compat profile version: 3.0
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.1
to me it seems almost like reading the destiontion pixels when blending fails.
The edges of the glyphs are blended against a black destination surface, while it actually is white.

Appears to be getting correct subpixel rendering for me now.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: