-remote broke between 1.0 RC1 and 1.0 RC2

RESOLVED DUPLICATE of bug 144027

Status

()

Core
X-remote
--
critical
RESOLVED DUPLICATE of bug 144027
16 years ago
16 years ago

People

(Reporter: Timothée Besset, Assigned: blizzard)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
eek
my mozilla desktop icon uses a script that calls -remote to avoid spawning
multiple mozilla processes
this has been working fine up to RC2
the command below used to work fine <= RC1, now they don't:

timo@antares:~/mozilla-rc2$ ./mozilla -remote
"openURL(http://www.google.fr,new-window)"
timo@antares:~/mozilla-rc2$ 

note that there is no error message, which means the command was actually
transmitted?

I noted that
./mozilla -remote "openURL()"
and
./mozilla -remote "openURL(http://www.google.fr)"
are still working fine though

If I can't have new-window working (I saw that new-tab is coming too .. yay!), I
can't use it.
(Reporter)

Comment 1

16 years ago
this is related to bug 99945 and 116653
Depends on: 99945, 116653

Comment 2

16 years ago
resembles bug 122498
(Reporter)

Comment 3

16 years ago
No I don't think it's 122498, since it works with some syntaxes and doesn't work
with new-window
And also, it appeared between 1.0 RC1 and 1.0 RC2, it is working fine in all <= RC1

Comment 4

16 years ago
could you do "echo $?" after it doesn't work?  0 means it thinks it succeeded.

you might also try mozilla-xremote-client:
mozilla-xremote-client "openURL(http://www.google.fr,new-window)"

(Reporter)

Comment 5

16 years ago
yeah, "echo $?" returns 0

as for mozilla-xremote-client, I had never used it, here's what happens when I try:

./run-mozilla.sh ./mozilla-xremote-client "openURL()"
this works, but the other cases
openURL(http://www.google.fr)
or
openURL(http://www.google.fr,new-window)
don't work
so, mozilla-xremote-client covers less cases that ./mozilla -remote
(Assignee)

Comment 6

16 years ago
mozilla-xremote-client and mozilla use the same code to communicate with the
running server.  There shouldn't be a difference.  Anyway, I can't reproduce
this.  Things are working fine here.
(Reporter)

Comment 7

16 years ago
ok, I backed up my ~/.mozilla and put it aside to start from scratch
with a brand new profile, -remote works fine
I'd rather avoid loosing my profile and restart from scratch though
I got plenty of login/pass and bookmarks ..
(Reporter)

Comment 8

16 years ago
to think of it, RC2 with my old profile has other symptoms:
the Help > About Plug-Ins and Help > About Mozilla don't work anymore (i.e., do
nothing)
that works fine with a new profile now too

Comment 9

16 years ago
you are probably seeing bug 144027
(Reporter)

Comment 10

16 years ago
definitely!
I removed chrome.rdf and I am able to use my old profile again

*** This bug has been marked as a duplicate of 144027 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
No longer depends on: 116653
You need to log in before you can comment on or make changes to this bug.