Many problems -- can't launch components mail, etc. (3rd party theme)

VERIFIED WORKSFORME

Status

SeaMonkey
General
--
critical
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Ken Tanzer, Assigned: Matti)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Can't launch mail, address book, composer, etc (either from "window" menu or w/
control-key shortcuts).  Also Help / About Mozilla & About Plugins the same.  A
new line is added to the window list, with no text (see screenshot attached).

This is specific to my user profile.  Running as root, or as another user, does
not have this behavior.  Everything ran fine from RC1.

Oddly, on the Window menu the "IRC Chat" item does not display an icon, while
all the others do.  Also, exiting this build closes its windows and appears to
have exited, but the processes are still running.

I am able to start the other components from the command line (mozilla -mail),
but the same behavior is exhibited, including can't launch browser from these
windows.

Will be happy to provide profile information & anything else to help debug
this--was really not expecting RC1->RC2 to break this bad for me!  (I would have
attached a gzip of my profile directory, but I'm assuming that's got all my
passwords included in it??).

Also some links seem to be dead (including the one from bugzilla-helper.html to
submit this bug!!)
(Reporter)

Comment 1

16 years ago
Created attachment 83277 [details]
Screenshot--Look at the window list on the WIndow Menu--also no icon on IRC Chat
(Assignee)

Comment 2

16 years ago
Have you instaleld third-party Themes ?
Can you try a new profile with "mozilla -profilemanager" ?

Comment 3

16 years ago
It was the same on Win2000 for me after installing RC2 and still using the old
profile from RC1. Don't know about the IRC icon, but no new window would open
(including view-source, Chatzilla and plain "Open new window".
Also Mozilla did not exit properly, had to be killed by Windows Taskmanager.

Try using a new profile, I'm sure it will help. But I'm really interested, what
profile changes might have caused this...
(Reporter)

Comment 4

16 years ago
I did not try creating a new profile, as I get normal functionality with my
other already-existing profiles.

It seems this was indeed theme-related.  I removed my "third-party" themes, and
everything seems to work ok now.  What's up with this?  Are themes given enough
power that they can break basic Mozilla functionality?
(Assignee)

Comment 5

16 years ago
yes, they have the power.
see http://bugzilla.mozilla.org/show_bug.cgi?id=138239#c4 for another problem.

I have no problem with a new version of the pinball Theme

-> wfm (broken Theme)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 6

16 years ago
v
Status: RESOLVED → VERIFIED
Summary: profile specific--Many problems inc. can't launch components mail, etc. → Many problems -- can't launch components mail, etc. (3rd party theme)
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.