Closed Bug 143944 Opened 20 years ago Closed 20 years ago

Mozilla should respect System's Email preferences

Categories

(SeaMonkey :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 11459

People

(Reporter: josh, Assigned: Matti)

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.0+)
Gecko/20020506
BuildID:    2002050608

Mac OS X has a system-wide preference for what app the user wants to use for
Email, but Mozilla does not respect this preference.  

If I click a mailto: link in Mozilla, it should tell my preferred email app to
create a new mail message (this is easily done through Apple's API for Internet
Config, I believe).

Reproducible: Always
Steps to Reproduce:
1. Click a mailto: link on a webpage

Actual Results:  Mozilla launches its own email app, regardless of whether or
not the user wants to use that program for email.

Expected Results:  Mozilla should have launched the user's preferred email app
and created a new message in that app (done via Apple APIs, so you don't need to
code in support for every email client :) )

*** This bug has been marked as a duplicate of 11459 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.