Closed Bug 1439634 Opened 2 years ago Closed 2 years ago

Update pdf.js to version 2.0.385

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 60
Tracking Status
firefox60 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

+++ This bug was initially created as a clone of Bug #1435814 +++

Changes since last update:
#9447 Expose some headers to fetch requests from the PDF.js Chrome extension
#9460 Use the correct stream position when reading `maxSizeOfInstructions` from the `maxp` table (issue 9458)
#9459 Respect workerSrc if set
#9427 Fallback to the built-in JPEG decoder when browser decoding fails, and attempt to handle JPEG images with DNL (Define Number of Lines) markers (issue 8614)
#9466 Refactor `PDFThumbnailViewer.scrollThumbnailIntoView` to avoid unnecessary DOM look-ups
#9453 Upstream the changes from: Bug 1432992 - Remove definitions of Ci, Cr, Cc, and Cu
#9468 Enable the `mozilla/avoid-removeChild` and `mozilla/use-includes-instead-of-indexOf` ESLint rules globally
#9465 Attempt to unify the `disableRange`/`contentLength` handling in the various network streams
#9472 Improve the interface for `PDFFindController`
#9473 Remove the non-`a.click()` case from the `DownloadManager`
#9475 Remove the actual `enableHandToolOnLoad` preference (PR 9040 follow-up)
#9420 Take the dictionary, and not just the image data, into account when caching inline images (issue 9398)
#9479 [api-major] Refactor viewer components initialization to reduce their dependency on the global `PDFJS` object
#9401 Make the test framework more resilient to errors.
#9470 Ensure that `JpegImage.getData` returns the correct data length when `forceRGBoutput == true` (issue 4888)
#9480 [api-major] Move the worker related options from the global `PDFJS` object

Looks like bug 792808 recently made changes to PdfStreamConverter.jsm without upstreaming them :(. I've filed an issue upstream for that and will re-apply the change locally for now to un-block this update.
https://github.com/mozilla/pdf.js/issues/9499
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/318cb586911e
Update pdf.js to version 2.0.385. r=bdahl
https://hg.mozilla.org/mozilla-central/rev/318cb586911e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
Blocks: 1442785
Duplicate of this bug: 1442995
Blocks: 1442995
You need to log in before you can comment on or make changes to this bug.