Update bug form.mdn for developer.mozilla.org product name

VERIFIED FIXED

Status

()

task
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: jwhitlock, Assigned: jwhitlock)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

a year ago
The bug form "form.mdn" needs an update to change the the product from "Mozilla Developer Network" to "developer.mozilla.org". Sorry I missed this in bug 1439608!
(In reply to John Whitlock [:jwhitlock] from comment #0)
> The bug form "form.mdn" needs an update to change the the product from
> "Mozilla Developer Network" to "developer.mozilla.org". Sorry I missed this
> in bug 1439608!

The file to modify is https://github.com/mozilla-bteam/bmo/blob/master/extensions/BMO/template/en/default/bug/create/create-mdn.html.tmpl. 

If you are comfortable with Perl and JavaScript you can fork and submit a PR, or I'll find someone to make this change.
Flags: needinfo?(jwhitlock)
(Assignee)

Comment 2

a year ago
The code seems straightforward enough. I've opened https://github.com/mozilla-bteam/bmo/pull/406.
Flags: needinfo?(jwhitlock)
Comment on attachment 8952598 [details] [review]
Patch

This looks good and I've approved and merged the patch on GitHub. ni? :dylan to schedule release.
Flags: needinfo?(dylan)
Attachment #8952598 - Flags: review?(ehumphries) → review+
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(dylan)
Resolution: --- → FIXED
(Assignee)

Comment 5

a year ago
It looks like there are a few more changes needed, such as .htaccess. I'm setting up Vagrant, and will open a new pull request.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Conveniently I need to do another push today, so I can get this out easily. What's wrong? if it's simple I can just do it for you. :)
Flags: needinfo?(jwhitlock)
(Assignee)

Comment 7

a year ago
I think I can have a PR ready in 30 minutes, do you mind reviewing?

There's a few more places where "Mozilla Developer Network" appears in the code:

https://github.com/mozilla-bteam/bmo/search?utf8=βœ“&q=Mozilla+Developer+Network&type=

extensions/BMO/template/en/default/bug/create/custom_forms.none.tmpl - Suggests the feedback form
extensions/BMO/lib/Data.pm - Forces the template form.mdn
.htaccess - RewriteRule for form.mdn that includes product name
extensions/BMO/Extension.pm - Migrates product_sec_group mappings
Flags: needinfo?(jwhitlock)
(Assignee)

Comment 8

a year ago
Oh, and the original problem is a permission denied error for the form:

http://bugzilla.mozilla.org/form.mdn

This was the problem I was originally trying to solve. Even with years of experience, I filed a bug for what I thought was the solution, not the actual problem...
I see! I casually looked at the patch too (but didn't review it) and missed that too.

I'll have time to review today, no worries.
(Assignee)

Comment 10

a year ago
PR opened - https://github.com/mozilla-bteam/bmo/pull/410. Sorry, I'm not familiar with adding PRs as attachments.

extensions/BMO/Extension.pm appears to be a migration from 2015, and that code block hasn't been updated since, so I decided to let the past remain in the past.
Pushed change up to bugzilla-dev, it should be live there in ~15-20 minutes, give that a look-over and then I'll do a prod push.
Flags: needinfo?(jwhitlock)
(Assignee)

Comment 12

a year ago
https://bugzilla-dev.allizom.org/ has the old product name "Mozilla Developer Network", needs to be updated to "developer.mozilla.org" to reproduce the bug and verify the fix (see bug 1439608)
Flags: needinfo?(dylan)
Of course, why would the dev db be at all up to date? sigh.


one sec.
Flags: needinfo?(dylan)
Okay, it seems to work now. It's of course a bit jarring (design-wise), but no worse than it was. :-)
(as an aside, I might try to get someone to make it look nicer in a supplemental bug).
(Assignee)

Comment 15

a year ago
https://bugzilla-dev.allizom.org/form.mdn works for me, and starting a new bug for developer.mozilla.org uses it. I'm not used to any other bug form, so it looks the same to me :) Ship it!
Flags: needinfo?(jwhitlock)
Status: REOPENED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → FIXED
(Assignee)

Comment 16

a year ago
* https://bugzilla.mozilla.org/form.mdn works without error
* Opening a new developer.mozilla.org bug uses the form

Thanks for helping with this product name change!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.