getUserMedia processing test page does not function accordingly

VERIFIED FIXED in Firefox 60

Status

()

defect
P2
normal
Rank:
15
VERIFIED FIXED
Last year
Last year

People

(Reporter: ccomorasu, Assigned: pehrsons)

Tracking

(Depends on 3 bugs, {regression})

60 Branch
mozilla60
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox58 unaffected, firefox59 unaffected, firefox60 verified)

Details

Attachments

(1 attachment)

[Affected versions]:
 Fx 60.0a1

[Affected platforms]:
 Windows 10 x64
 Ubuntu 16.04 LTS x64
 macOS X 10.13.2

[Steps to reproduce]:
 1. Launch Firefox.
 2. Go to this page: "https://jsfiddle.net/jib1/n7bmkjnf/"  and share the microphone.
 3. Toggle the following checkboxes: echoCancellation, noiseSuppression, autoGainControl.

[Expected result]:
 The checkboxes function accordingly.

[Actual result]:
 The checkboxes cannot be checked.

[Regression range]:
 Last good: 20180131100706
 First bad: 20180201100326
 Pushlog: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7b46ef2ae1412b15ed45e7d2367ca491344729f7&tochange=17ade9f88b6ed2232be51bc02c6860562c3d31dc

[Additional notes]:
 This test page is working on Google Chrome.
Has Regression Range: --- → yes
Has STR: --- → yes
Andreas, your fixes for Bug 1299515, Bug 1426718, Bug 1299516 and Bug 1408294 landed in that regression range. Do you mind having a quick look to see if this is related?
Rank: 15
Flags: needinfo?(apehrson)
Priority: -- → P2
Assignee: nobody → apehrson
Blocks: 1299515
Flags: needinfo?(apehrson)
Component: WebRTC → WebRTC: Audio/Video
Keywords: regression
Primarily it's getSettings that doesn't work.
Status: NEW → ASSIGNED
Good catch this. We still applied constraints, but GetSettings would always return an empty set of settings even though we kept track of them internally.
(In reply to Munro Mengjue Chiang [:mchiang] Be Mozillian since 1/19/2018 from comment #4)
> Here are some related discussions for your reference.
> https://github.com/w3c/mediacapture-main/issues/466

Thanks. This is just for fixing the regression though. I think we're pretty well aligned with track target settings otherwise.
Comment on attachment 8953917 [details]
Bug 1440252 - Implement MediaEngineWebRTCMicrophoneSource::GetSettings.

https://reviewboard.mozilla.org/r/223066/#review229056

It would be great to have a test for this, now that we have loopback devices on Linux. It can be in a separate bug.
Attachment #8953917 - Flags: review?(padenot) → review+
We have some existing bugs for tracking those tests.
Depends on: 1406372, 1406376, 1406377
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bf6a40668971
Implement MediaEngineWebRTCMicrophoneSource::GetSettings. r=padenot
https://hg.mozilla.org/mozilla-central/rev/bf6a40668971
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
I can confirm this issue is fixed, I verified using Fx 60.0a1 (build ID: 20180227100126), on Windows 10 x64, Ubuntu 16.04 LTS x64 and mac OS X 10.12.6.

Cheers!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.