Closed Bug 1440281 Opened 2 years ago Closed 2 years ago

Crash in mozilla::DisplayItemData::Destroy

Categories

(Core :: Web Painting, defect, critical)

Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 --- fixed

People

(Reporter: calixte, Assigned: mattwoodrow)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-1a784524-24e0-4ca8-89a4-87e270180222.
=============================================================

Top 10 frames of crashing thread:

0 libxul.so mozilla::DisplayItemData::Destroy layout/style/nsStyleContextInlines.h:179
1 libxul.so nsDisplayWrapList::~nsDisplayWrapList 
2 libxul.so nsDisplayWrapList::Destroy layout/painting/nsDisplayList.h:2127
3 libxul.so nsDisplayList::DeleteAll layout/painting/nsDisplayList.cpp:2836
4 libxul.so nsDisplayWrapList::Destroy layout/painting/nsDisplayList.h:4927
5 libxul.so nsDisplayList::DeleteAll layout/painting/nsDisplayList.cpp:2836
6 libxul.so nsDisplayWrapList::Destroy layout/painting/nsDisplayList.h:4927
7 libxul.so nsDisplayList::DeleteAll layout/painting/nsDisplayList.cpp:2836
8 libxul.so nsDisplayWrapList::Destroy layout/painting/nsDisplayList.h:4927
9 libxul.so nsDisplayList::DeleteAll layout/painting/nsDisplayList.cpp:2836

=============================================================

There are 13 crashes in nightly 60 with buildid 20180221220150.
The pushlog for this build is [1].
We've 3 crashes with the same signature in beta 59.

:emilio, could you investigate please ?

[1] https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dd6caba14142&tochange=994a684a7564
Flags: needinfo?(emilio)
Looks like Matt's push for bug 1436904 touched DisplayItemData, so if I had to guess, I'd guess that :)
Blocks: 1436904
Component: Layout → Layout: Web Painting
Flags: needinfo?(emilio) → needinfo?(matt.woodrow)
Fixed by backing out bug 1436904.
Assignee: nobody → matt.woodrow
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(matt.woodrow)
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
You need to log in before you can comment on or make changes to this bug.