Closed Bug 1440302 Opened 2 years ago Closed 2 years ago

Mozilla Firefox Nightly 60.0a1 (2018-02-22) crashes in [@ mozilla::FrameLayerBuilder::GetOldLayerForFrame ]

Categories

(Core :: Web Painting, defect, critical)

60 Branch
x86_64
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla60
Tracking Status
firefox-esr52 --- unaffected
firefox58 --- unaffected
firefox59 --- unaffected
firefox60 + verified

People

(Reporter: Virtual, Assigned: mattwoodrow)

References

(Blocks 1 open bug)

Details

(Keywords: crash, nightly-community, regression, Whiteboard: [fixed by patch backout from bug #1436904])

Crash Data

There are 658 crashes (from 296 installations) in nightly 60 with buildid 20180222101929. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1436904.

[1] https://hg.mozilla.org/mozilla-central/rev?node=27640f52e188
Blocks: clouseau, 1436904
Component: Layout → Layout: Web Painting
Flags: needinfo?(matt.woodrow)
Crashes we've in 58 & 59 are not related to bug 1436904.
This link seems to reliably reproduce the crash for me:
https://twitter.com/NRATV/status/966534627522301952
This is crashing a lot for me. If we can't get a fix in in time for the next nightly I think we should back out the offending patch.
Looks like the offending patch was indeed backed out a couple hours ago, in bug 1436904 comment 10.  So hopefully this should be better in the next Nightly.
Fixed by backing out bug 1436904.
Assignee: nobody → matt.woodrow
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(matt.woodrow)
Resolution: --- → FIXED
Target Milestone: --- → mozilla60
Looks fixed with respined Mozilla Firefox Nightly 60.0a1 (2018-02-22) (64-bit) [rev: https://hg.mozilla.org/mozilla-central/rev/5e9bd04333f20e00911b8c1dfbf2b2e070c61e2d ]
Thanks!
Status: RESOLVED → VERIFIED
Whiteboard: [fixed by patch backout from bug #1436904]
You need to log in before you can comment on or make changes to this bug.