Closed Bug 1440524 Opened 2 years ago Closed 2 years ago

Update Screenshots to version 30.0.0

Categories

(Firefox :: Screenshots, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
Firefox 60
Tracking Status
firefox60 --- fixed

People

(Reporter: _6a68, Assigned: _6a68)

Details

Attachments

(2 files)

Update Screenshots to 30.0.0, latest version in github.

Complete changelog: https://github.com/mozilla-services/screenshots/blob/ab3ebc4a4c2db04de332213e9e4150b1f4f8b913/CHANGELOG.md

Add-on changes:

* Remove one of the addon icon svgs. ([#4132](https://github.com/mozilla-services/screenshots/issues/4132)) [b456233](https://github.com/mozilla-services/screenshots/commit/b456233)
* Include onboarding slides in user timing measurements. Fixes [#4097](https://github.com/mozilla-services/screenshots/issues/4097) [69b58f7](https://github.com/mozilla-services/screenshots/commit/69b58f7)
* Use Performance.now for interaction timings. Fixes [#4054](https://github.com/mozilla-services/screenshots/issues/4054) [3119bb4](https://github.com/mozilla-services/screenshots/commit/3119bb4)
* Show loader animation on truncated full page download/copy. ([#3861](https://github.com/mozilla-services/screenshots/issues/3861)) [6fa7f3a](https://github.com/mozilla-services/screenshots/commit/6fa7f3a)
* Fix lint issues. ([#4076](https://github.com/mozilla-services/screenshots/issues/4076)) [51dff4c](https://github.com/mozilla-services/screenshots/commit/51dff4c)
* Use double quotes. ([#3977](https://github.com/mozilla-services/screenshots/issues/3977)) [2764e9d](https://github.com/mozilla-services/screenshots/commit/2764e9d)
* Use eqeqeq. ([#3977](https://github.com/mozilla-services/screenshots/issues/3977)) [35f01a4](https://github.com/mozilla-services/screenshots/commit/35f01a4)
* Use prefer-const. ([#3977](https://github.com/mozilla-services/screenshots/issues/3977)) [eefee3d](https://github.com/mozilla-services/screenshots/commit/eefee3d)
* Replace var with let or const. ([#3977](https://github.com/mozilla-services/screenshots/issues/3977)) [6824d8b](https://github.com/mozilla-services/screenshots/commit/6824d8b)
* Enable consistent-return. ([#3977](https://github.com/mozilla-services/screenshots/issues/3977)) [ed632d6](https://github.com/mozilla-services/screenshots/commit/ed632d6)
* apply svgo to all svgs. Fixes [#3853](https://github.com/mozilla-services/screenshots/issues/3853) [28ef28c](https://github.com/mozilla-services/screenshots/commit/28ef28c)
* Suppress errors encountered when sending timing or events pings
  Analytics network errors should never be user-visible. [73c1340](https://github.com/mozilla-services/screenshots/commit/73c1340)
* Cancel some user timing measurements when page visibility changes to 'hidden'
  JS background budgeting in Firefox 58 might cause Screenshots execution
  to slow down if the user switches tabs while waiting for the UI to
  update.
  Exclude cases where the user timing event ends with an upload, since the
  result of a successful upload is to switch tabs (to the shot page of the
  uploaded shot).
. Fixes [#4055](https://github.com/mozilla-services/screenshots/issues/4055) [588d2e7](https://github.com/mozilla-services/screenshots/commit/588d2e7)
* Fire an internal-only event if Screenshots is in a document that is backgrounded
  Use the Page Visibility API to detect when a given window loses focus. [2aed29b](https://github.com/mozilla-services/screenshots/commit/2aed29b)
* Upstream changes to loader calls in bootstrap.js context
  Cu.import has been replaced with ChromeUtils.import, and
  XPCOM.defineLazyModuleGetter has been replaced with
  ChromeUtils.defineModuleGetter. Adjust our code accordingly.
  See bugzilla bug 1431533 for details. [07b3b39](https://github.com/mozilla-services/screenshots/commit/07b3b39)
Comment on attachment 8953307 [details]
Bug 1440524 - Export Screenshots 30.0.0 to Firefox (translations only);

https://reviewboard.mozilla.org/r/222574/#review228536
Attachment #8953307 - Flags: review?(francesco.lodolo) → review+
My previous Try push landed at the exact time the Talos windows machines got upgraded, so there is an apparent dramatic improvement in test perf between my push and the previous m-c base commit:

https://treeherder.mozilla.org/perf.html#/compare?originalProject=mozilla-central&newProject=try&newRevision=1d449ccf4c090fa4e6c41c18726d77b19e4c677d&framework=1&selectedTimeRange=172800

There should be a new base commit on new hardware by now. Re-pushing a new set of Talos runs, which should be representative of any actual perf impact caused by the version 30 export:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=10b92b437ffe6d0804c6ea0a7ea904e6030f3373
Comment on attachment 8953307 [details]
Bug 1440524 - Export Screenshots 30.0.0 to Firefox (translations only);

https://reviewboard.mozilla.org/r/222574/#review228790
Attachment #8953307 - Flags: review?(ianb) → review+
Comment on attachment 8953308 [details]
Bug 1440524 - Export Screenshots 30.0.0 to Firefox (code excluding translations);

https://reviewboard.mozilla.org/r/222576/#review228804
Attachment #8953308 - Flags: review?(ianb) → review+
Whoops, had to add another bug fix to the export.

Changelog addition:

* Remove two extra handlers and add more conditions around ctrl+c. ([#4113](https://github.com/mozilla-services/screenshots/issues/4113)) ([#4149](https://github.com/mozilla-services/screenshots/issues/4149)) [e82ef8e](https://github.com/mozilla-services/screenshots/commit/e82ef8e)
Assignee: nobody → jhirsch
QA didn't find any new blockers. Merging
Pushed by jhirsch@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/81c57d6ab455
Export Screenshots 30.0.0 to Firefox (translations only); r=flod,ianbicking
https://hg.mozilla.org/integration/autoland/rev/ab8c5bc86ac6
Export Screenshots 30.0.0 to Firefox (code excluding translations); r=ianbicking
https://hg.mozilla.org/mozilla-central/rev/81c57d6ab455
https://hg.mozilla.org/mozilla-central/rev/ab8c5bc86ac6
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 60
You need to log in before you can comment on or make changes to this bug.