Closed Bug 1440601 Opened 3 years ago Closed 2 years ago

Tabsharing exposed on Fennec Nightly. Disable it.

Categories

(Core :: WebRTC: Audio/Video, enhancement, P2)

31 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox60 --- disabled
firefox65 --- disabled
firefox66 --- disabled
firefox67 --- fixed

People

(Reporter: pehrsons, Assigned: snorp)

References

Details

Attachments

(4 files)

It shows up in enumerateDevices on Talky [1] but cannot be started through gUM on [2].

Seems to be triggered by [3], which is android only.


[1] See the camera drop-down chooser before joining a room, e.g., on https://talky.io/random-test-room-24634124124
[2] https://mozilla.github.io/webrtc-landing/gum_test.html -- try Screen, Window or Application
[3] https://searchfox.org/mozilla-central/rev/bd05e3853c6e982e2a35c1cc404b987b2bc914d6/mobile/android/components/MobileComponents.manifest#99-103
Rank: 22
Priority: -- → P3
See Also: → 1439529

Paul discovered today that this is a working feature added in bug 928096 (Nightly only)! Added 6 years ago, and enabled in Nightly only, we must have missed it in bug 1127522 when we removed the whitelist pref in favor of our Desktop UI.

It shows up as a regular camera choice:

  • Front facing camera
  • Choose a tab to stream
  • Back facing camera

..and when chosen, takes you to a working tab picker (see this screenshot), which then share your tab with your peer successfully.

It's implemented as a camera choice rather than through the mediaSource constraint—which is why it shows up under "Video" not "Screen" or "Window" in [2] in comment 0.

Unfortunately, this feature has a number of problems, and should be disabled until they're resolved:

  1. Picker doesn't alert the end user to the dangers of screen sharing like the Desktop prompt does. It would need to do that.
  2. This feature should not be exposed as a camera. It should be moved to navigator.mediaDevices.getDisplayMedia().
  3. Most android devices appear unable to share camera and screen simultaneously. This is left to web sites to navigate.
  4. Broken labels (this screenshot),
Rank: 22 → 14
Priority: P3 → P2
Summary: Tabsharing exposed to enumerateDevices on Fennec Nightly → Tabsharing exposed on Fennec Nightly. Disable it.

cc android team for comment.

Flags: needinfo?(astevenson)

NIing Liz so she can add this to our Fennec backlog.
NIing Snorp & Stefan as this problem might affect GeckoView & AC as well.

Flags: needinfo?(snorp)
Flags: needinfo?(lhenry)

Andreas, you can do that simply by setting a priority and the nightly version's status flag (in this case 67)

Flags: needinfo?(lhenry)
Flags: needinfo?(astevenson)

I put a patch up to disable this.

Flags: needinfo?(snorp)
Pushed by jwillcox@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d83d3c63a428
Disable TabSource on Android r=petru
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b66f55b054d
Disable TabSource on Android r=petru
Backout by nbeleuzu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aab6db0102cf
Backed out changeset d83d3c63a428 for causing TL bustages.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee: apehrson → snorp
Duplicate of this bug: 1181691
You need to log in before you can comment on or make changes to this bug.