Mozilla looses session cookie

RESOLVED FIXED

Status

()

Core
Networking: Cookies
--
major
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: John Andre Taule, Assigned: Stephen P. Morse)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051013

We use a cookie as a key to information on our service.

When the cookie is lost, autentication is also lost, along with other info to
make the experience more user-friendly.

We use php-skripts to serve locked images, and it is when using pages that
contains these that the cookie is lost. 

My guess is that this build (RC1 also had the problem) dont always send the
cookie information. <img src="somescript.php?bid=123412"> is my guess. The pre
prerealease builds where nearly 100% on www.eurofoto.co.uk. 

Reproducible: Always
Steps to Reproduce:
1. http://www.eurofoto.co.uk/login.php
2. Check for auth (text in the blue field on top changes to you are signed in
as, and also on the blue field to the left).
3. http://www.eurofoto.co.uk/public_albums.php
4. Select an album
5. Reload original page, and you are no longer signed in wich means that the
cookie is lost.

To reproduce even better, upload a few images, and the browse one of your own
images.

Actual Results:  Cookie is lost (to be more precise, a new cookie is set), user
is signed of.

Expected Results:  Always send the cookie to the server.

This bug prevents me to test our pages on Mozilla. Its also bad since I cannot
recomend this browser to our customers. Which leaves the only browser to IE, and
thats BAD.
Can you send a working Username/password to the developer or add it to this bug ?
Severity: blocker → major
(Reporter)

Comment 2

16 years ago
Working user/password: 

username: testuser@eurofoto.no
password: testuser

Shortcut: http://www.eurofoto.co.uk/albumlist.php
(Assignee)

Comment 3

16 years ago
Is your cookie-acceptance pref set to originating-server-only?  If so, try 
setting it to accept-all and see if that makes a difference.
(Assignee)

Comment 4

16 years ago
Although the symptoms are different, the patch just posted to bug 137079 will 
probably fix this bug as well.  Can someone who can reproduce this bug please 
apply that patch and see if it takes care of this problem.
(Assignee)

Updated

16 years ago
Depends on: 137079
(Assignee)

Comment 5

16 years ago
Being marked fixed since the patch for 137079 is checked in on trunk.  However 
it is not yet fixed on the branch.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Assignee)

Updated

16 years ago
Keywords: fixed1.0.0

Comment 6

16 years ago
yes the patch was checked into the branch according to a comment in bug# 137079

verified on the branch - 05/23/02 builds, winNT4, linux rh6, mac osX
Keywords: verified1.0.0
You need to log in before you can comment on or make changes to this bug.