Closed Bug 1440973 Opened 2 years ago Closed 2 years ago

The Synced Tabs menu does not open after the second time

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1434376
Tracking Status
firefox60 --- fixed

People

(Reporter: magicp.jp, Unassigned)

References

Details

(Keywords: regression)

Steps to reproduce:
1. Launch Nightly
2. Navigate to Library button > Synced Tabs > Go back to Library > Synced Tabs again

Actual results:
The Synced Tabs menu does not open after the second time.
The following error is logged in the browser console.

Subview PanelUI-remotetabs is already open. PanelMultiView.jsm:611


Expected results:
Works fine.


Regression range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=05a8ecb88424cbc51bc705f077ab41867f22619a&tochange=01e3d1408dbe8552f22ebb2f1d71d86e11bd7f14


See also:
Bug 1424823
Blocks: 1439358
Has Regression Range: --- → yes
Has STR: --- → yes
See Also: → 1424823
Flags: needinfo?(paolo.mozmail)
Keywords: regression
I can't reliably reproduce this on macOS. What OS are you seeing this on, and can you reproduce on a clean profile?
Flags: needinfo?(magicp.jp)
This should be re-tested once bug 1434376 lands, let me know if the issue persists.
Blocks: 1434376
Flags: needinfo?(paolo.mozmail)
(In reply to :Gijs from comment #1)
> I can't reliably reproduce this on macOS. What OS are you seeing this on,
> and can you reproduce on a clean profile?

I can reproduce this with a clean profile (Build ID: 20180225220119) on macOS 10.13.2, ubuntu 17.10 and Windows 10.
Flags: needinfo?(magicp.jp)
(In reply to magicp from comment #3)
> (In reply to :Gijs from comment #1)
> > I can't reliably reproduce this on macOS. What OS are you seeing this on,
> > and can you reproduce on a clean profile?
> 
> I can reproduce this with a clean profile (Build ID: 20180225220119) on
> macOS 10.13.2, ubuntu 17.10 and Windows 10.

Oh, I think I got confused with the STR from bug 1424823. I reproduced on an older nightly when I tried again this morning, but this looks fixed to me on current nightly from this morning -- though now there's bug 1441154 instead. Do you see the same thing?
Flags: needinfo?(magicp.jp)
(In reply to :Gijs from comment #4)
> Oh, I think I got confused with the STR from bug 1424823. I reproduced on an
> older nightly when I tried again this morning, but this looks fixed to me on
> current nightly from this morning -- though now there's bug 1441154 instead.
> Do you see the same thing?

Works fine in the latest Nightly build. Thanks!
Flags: needinfo?(magicp.jp)
Duping this to bug 1434376 given that seems to have fixed it. Thanks!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1434376
You need to log in before you can comment on or make changes to this bug.