Closed Bug 1441058 Opened 2 years ago Closed 2 years ago

Custom search engine using POST doesn't work in container tabs

Categories

(Firefox :: Address Bar, defect)

58 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1435615
Tracking Status
firefox58 --- affected
firefox59 --- affected
firefox60 --- affected

People

(Reporter: stoically, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20180208175058

Steps to reproduce:

Created fresh profile. Changed config to enable containers:

privacy.userContext.enabled true
privacy.userContext.longPressBehavior 2
privacy.userContext.ui.enabled true

Installed Custom Startpage.com Search-Engine that uses POST:
- Navigate to https://www.startpage.com/do/preferences
- Click GENERATE URL top right (default setting is POST)
- Scrolls down
- Click INSTALL CUSTOM PLUGIN
- Tick the "Make this the current search engine" checkbox and click Add
- Open new tab, enter "example" into address bar, startpage results open
- Longpress new tab button, select container to open new tab, enter "example" into address bar, startpage homepage opens (no results)


Actual results:

Searching using the address bar didn't produce results in a container tab


Expected results:

Searching using the address bar should produce results in a container tab


Also tested with Nightly 60.0a1 and with Firefox58.0.2 under Windows10
Workarounds to get it working are:
- Set browser.newtabpage.activity-stream.enabled to false
- Navigate to a website in the container tab first, then do the search
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID 	20180301024724

I was able to reproduce this issue on the latest Firefox Release and the latest Nightly using Windows 10x64, Mac 10.13 and Arch Linux x64.

> Workarounds to get it working are:
> - Set browser.newtabpage.activity-stream.enabled to false

This work around does not work on Nightly because this pref no longer exists.
Status: UNCONFIRMED → NEW
Component: Untriaged → Address Bar
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
This is the same underlying problem as bug 1435615 and in my testing is fixed by the patch there.  It will land on mozilla-central soon and should be in 61.

I'm not sure whether it's better to mark this as a duplicate or as depending on the other bug.  I guess the latter since the STR are different.
Depends on: 1435615
Meh, duplicate is probably better.
Status: NEW → RESOLVED
Closed: 2 years ago
No longer depends on: 1435615
Resolution: --- → DUPLICATE
Duplicate of bug: 1435615
You need to log in before you can comment on or make changes to this bug.