Closed Bug 1441862 Opened 4 years ago Closed 4 years ago

WebExtension has a white window after a while

Categories

(WebExtensions :: Untriaged, defect)

60 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1416505

People

(Reporter: miraty, Unassigned)

Details

Attachments

(5 files)

Attached image The bug in action
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180228100110

Steps to reproduce:

I have installed an extension (Privacy Badger, HTTPS Everywhere, and others), launch the popup of this extension and wait a moment.


Actual results:

A white window appear instead of the normal window. This happens after a few seconds to a few minutes. See the screenshot.


Expected results:

The popup of the extension should have remained as it was.
Attached image The original popup
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180228100110

I couldn't reproduce the issue under Windows 10 x64 using Nightly 60.0a1 Fr build(20180228100110), the latest Nightly 60.0a1 -en-US build nor latest Nightly 60.0a1 FR build using the steps from the description and with Privacy Badger and HTTPS Everywhere installed.

Could you please paste here the list with all Extensions listed in about:addons-Extensions section?

Also, please retest using the latest Nightly, using a new profile (with extensions installed), you have the steps here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager and report back the results.
Flags: needinfo?(miraty)
I have remaked the bug with the latest version of Nightly, with a new profil and only HTTPS Everywhere, Privacy Badger and Wappalyser.

My graphics cards are Intel(R) HD Graphics 4600 and NVIDIA GeForce GT 730M.
The drivers are up to date.
Flags: needinfo?(miraty)
Attached image The bug remade
Attached image The original popup
Managed to reproduce the issue on Windows 10 x64 on latest Nightly 60.0a1 (2018-03-06).
I reproduced the issue with webextension pop-up opened while the Windows 10 theme changed the browser title bar colour.

miraty, what Windows theme do you use? Could you please try to reproduce the bug with Windows 10 theme vs Windows theme?

Thanks
Status: UNCONFIRMED → NEW
Component: Untriaged → Theme
Ever confirmed: true
Flags: needinfo?(miraty)
Component: Theme → WebExtensions: Untriaged
Product: Firefox → Toolkit
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1416505
I use the Windows theme generated by DisplayFusion. 
It might be the cause of the issue. 
The window became white when DisplayFusion change my wallpaper.
There is no problem when DisplayFusion is not running.

Thanks
Flags: needinfo?(miraty)
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.